Support » Plugin: Google Places Reviews » INVALID REQUEST: Please check that this widget has a Google Place ID set.

  • Hello!

    I can’t get the plugin to work.

    I have created and activated the Google Api key. This is entered and saved in the plugin. I don’t get a suggestion search. I get an error message instead. The dashboard in the google api console reacts to input!

    This ist the error message in the frontend:

    INVALID REQUEST: Please check that this widget has a Google Place ID set.

    what am I missing?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Done. Runs 🙂

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi @tobulk — is this resolved? Here’s our documentation on the plugin:
    https://wordimpress.com/documentation/google-places-reviews/

    Generally, that error is related to the API key not being configured correctly, or the widget has not yet populated a business to display the reviews.

    Also, I wanted to let you know that we are in the middle of totally revamping how we do Business Reviews as a whole. If you’re interested in learning more about what we’ve got up our sleeves and maybe doing some beta testing for us, feel free to sign-up here: https://wpbusinessreviews.com

    Let me know if I can help further. Thanks!

    Matt,

    I’m having the same problem. API is good, the place is popping in Google Places with a Place ID.

    But the lookup in the widget is not working…

    Signed up for the beta too, if you think that would be helpful.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    @artc1209 — if the widget is not populating suggestions, then it’s most likely a plugin conflict.

    I’d suggest using the Health Check plugin to troubleshoot that. It will allow you to deactivate all plugins and put your site on a default theme ONLY for yourself — your live visitors will not see that. We have a write-up on that here:
    https://givewp.com/documentation/resources/troubleshoot-wordpress-websites-health-check/

    Then you can enable plugins one at a time and test again until you see the problem again. Then let me know which plugin caused the conflict and I can take a closer look at replicating the issue for you.

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘INVALID REQUEST: Please check that this widget has a Google Place ID set.’ is closed to new replies.