Support » Plugin: Reviews and Rating – Google My Business » Invalid request error

  • Resolved Silvana Borges

    (@silvanaborges)


    Hi!
    I did all the set up on the plugin and google side and I get this error in the retrieved data tab:
    “html_attributions”: [],
    “status”: “INVALID_REQUEST”

    Any ideas on the reason why I’m getting this? Here’s some more information:
    1) I was unable to find my business account in the Place ID Finder, but I do get the ID. My location is not set up for a specif place, but for Brazil

    2) Advanced tab shows:
    X API Key and Place ID are both set and valid;
    X Five or more reviews retrieved from Google
    API and Place Id are both correct

    3) I only have 2 reviews now, not sure if there’s a minimum necessary

    Do you think my case is addressed by the last question in FAQ?

    Thanks 😉

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Design Extreme

    (@designextreme)

    @silvanaborges Thanks for getting in touch and the detailed explanation.

    This issue is covered in the plugin’s requirements and in the plugin itself.

    A requirement of the plugin: the Place ID must be attached to a specific location; not a region or coverage area. The Place API returns no data when the Place ID is not listed in their Place ID Finder. If you get the ID by looking at the source code for “placeid” or “pid” this is not accepted as a valid specific location in terms of the Place API.

    I recommend changing the region/coverage area to a specific location as others have had success here.

    The overall review count does not affect the Place API data.

    I hope this explains the matter.

    • This reply was modified 1 year ago by Design Extreme. Reason: Second to last line
    Thread Starter Silvana Borges

    (@silvanaborges)

    Thank you so much for the prompt reply. Both the plugin and support of yours are great. Many thanks!

    Plugin Author Design Extreme

    (@designextreme)

    Thanks @silvanaborges! 🙂

    Piramidon

    (@piramidon)

    Do you, by any chance, plan on switching to the My Business API in order to make the plugin work for service area businesses?

    Plugin Author Design Extreme

    (@designextreme)

    @piramidon Thanks for the suggestion. I will look into this in the next round of this plugin’s development.

    Piramidon

    (@piramidon)

    @designextreme Thanks! I’ll keep a lookout, because I can’t use it at the moment 🙁

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Invalid request error’ is closed to new replies.