Support » Plugin: WooCommerce Stripe Payment Gateway » Invalid Request Error

  • Resolved akshat05

    (@akshat05)


    Hello,

    I updated woocommerce and stripe to latest version and after that the payments stopped working, below is the response:

    {
     "error": {
       "message": "The reusable source you provided is consumed because it was previously charged without being attached to a customer or was detached from a customer. To charge a reusable source multiple time you must attach it to a customer first.",
       "type": "invalid_request_error"
     }
    }

    Kindly help me out with the solution.
    Thanks

Viewing 1 replies (of 1 total)
  • Plugin Support Phil

    (@fullysupportedphil)

    Automattic Happiness Engineer

    @akshat05 That error typically means that you are attempting to retrying a transaction with an invalid token, or that you are trying to use the incorrect token.

    Do you have a staging site where you can run two quick tests? If you don’t already have a staging site set up, check with your hosting company as many offer this as part of their packages. Otherwise, you can use a free plugin such as WP Staging to set one up.

    On the staging site, please switch to the default Twenty Nineteen or Storefront theme with no customizations. Then disable ALL plugins, except for WooCommerce and Stripe. Try making another test transaction at that point. If the error is resolved, you can begin reactivating your plugins and them one at a time as you continue testing. Once you find the plugin/theme causing the error, make sure it’s up to date and then contact it’s developer.

    If you are still able to replicate the issue with all other plugins disabled and using one of the above themes, we’ll need to do some deeper troubleshooting. At that point could you please contact us at WooCommerce.com > My Account > Tickets? You may need to create an account. When opening the ticket, please make sure to select the Stripe plugin. We will be able to help you further there.

Viewing 1 replies (of 1 total)
  • The topic ‘Invalid Request Error’ is closed to new replies.