Support » Plugin: MainWP Dashboard » "Invalid request" – cannot connect sites

  • Resolved quanto

    (@quanto)


    I installed MainWP Dashboard on a clean localhost server (no other plugins)

    I tried to connect 2 different wordpress child installs on the same localhost and 1 live child site.

    I use MainWP Dashboard 3.0.1 and MainWP Child 3.0.1.

    The only server error on the Dashboard site is:
    SSL Warnings = empty error:02001003:system library:fopen:No such process

    but I don’t use SSL on any of these sites.

    The Dashboard sees the sites by testing the connection:

    Connection test successful. (URL: total.dev (IP: 127.0.0.1) – Received HTTP-code: 200 (OK))
    To find out more about what your HTTP status code means please click here to locate your number (200)

    Why I cannot connect the dashboard and the child sites?

    I always have: Error – Invalid request.

    I tried adding the child sites by disabling “Require Unique Security ID”, I got the same error.

    I activated and deactivated the dashboard and child plugins, all the same

    Any help?

    https://wordpress.org/plugins/mainwp/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author mainwp

    (@mainwp)

    I believe you submitted a ticket to support for this but just in case anyone else needs the information:

    Before the child plugin will connect it checks to see if the OpenSSL is available, if not it falls back to md5 encryption. Since your site is giving an an error for SSL the plugin does not know to fall back and instead refuses to allow the connection. This is not the same as using HTTPS in your domain name.

    It would be best to start by contact your host to find out why your SSL is giving an error and have them correct it.

    If you need anything else, please reply to your help desk ticket.

    photocurio

    (@photocurio)

    I’m having the same problem: SSL Warnings are blocking the requests to hook up child sites. Same error message.

    My WordPress sites are all on a corporate intranet IIS server. Unfortunately I am the guy managing this host! I can’t find anything on solving it.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘"Invalid request" – cannot connect sites’ is closed to new replies.