Support » Plugin: WP LinkedIn » invalid redirect_uri. This value must match a URL registered with the API Key.

  • Resolved victor.bexelius

    (@victorbexelius)



    Hello!
    So I just upgraded the module to Version 2.5 which required me to generate the token again.

    I followed the guides from the forum regarding the invalid redirect_uri and just modified the redirect_uri to “http://victorbexelius.se/?oauth=linkedin”

    When I do this with Version 2.5 – the redirect works and returns me to my domain (page). But the validation fails, and I am prompted that the token is expired.

    Here is the original request:
    https://www.linkedin.com/uas/oauth2/authorization?response_type=code&client_id=77p88zdysqg2zw&scope=r_basicprofile&state=937949bbadf87ff85bc442dc48b79edc975c2583&redirect_uri=http%3A%2F%2Fvictorbexelius.se%2Fwp-content%2Fplugins%2Fwp-linkedin%2Fredir.php%3Fto%3Dhttp%253A%252F%252Fvictorbexelius.se%252Foauth%252Flinkedin%252F%253Fr%253D%25252Fwp-admin%25252Foptions-general.php%25253Fpage%25253Dwp-linkedin

    And here is the modified request as described in the forum:
    https://www.linkedin.com/uas/oauth2/authorization?response_type=code&client_id=77p88zdysqg2zw&scope=r_basicprofile&state=937949bbadf87ff85bc442dc48b79edc975c2583&redirect_uri=http://victorbexelius.se/?oauth=linkedin

    Did I miss something this time? Would be thankful for any help with this issue

    Best regards

    Victor

    https://wordpress.org/plugins/wp-linkedin/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi again – so I uninstalled v 2.5 – and re-installed v 2.4.2

    Now everything works – and I did not have to refresh the token (it was stored and intact in the database-tables with the credentials for the API already).

    I was thinking:

    1. I did an update of v2.4.2 module from inside WordPress admin.

    2. There might be some issues with the update from v2.4.2 to v2.5 (database issues?)

    3. Perhaps one should do a complete uninstallation of v2.4.2 and then a fresh install of v.2.5?

    I dont have time to verify #3 – but just a thought from my side.

    I will stick with v.2.4.2 for now

    Best regards

    Victor

    Plugin Author Claude Vedovini

    (@cvedovini)

    from your url it seems to me you are on a multisite installation, is that right?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘invalid redirect_uri. This value must match a URL registered with the API Key.’ is closed to new replies.