Support » Fixing WordPress » Invalid post type on wp-admin/edit.php

  • Resolved honza.skypala

    (@honzaskypala)


    Hi all,

    sudenly I’m getting an error Invalid post type when I try to access “Posts” (i.e. file wp-admin/edit.php) in the admin area.

    Also, I cannot edit any existing post (using a direct URL), then I get an error “Sorry, you are not allowed to edit posts in this post type.”

    Other admin pages do work fine. I can access the dashboard, themes, tags, even pages, all that works fine.

    I tried to disable all the plugins and switched to a theme TwentyFifteen, but it does not help. Still getting the same problem.

    I’m running my site on WordPress since year 2009, never faced such problem. Any idea?

Viewing 12 replies - 1 through 12 (of 12 total)
  • One more finding: if I go to New Post, then the webpage loads, but it misses the box “Publish” (so I cannot publish the post, or save draft). Other boxes are present on the webpage.

    Hey,
    I am having absolutely the same issues for about 1 hour. Started when I was actually working on one of my pages. I am hosted on Wedos.

    Then I tried already reinstall WordPress like 5 times,, including setting up a new DB. Even after fresh installation, I can see count of pages after going to Pages, but none in the list of actual pages (http://i.imgur.com/QtsNWDb.png). Getting “Invalid post type.” error when I click on Posts, or cant create new pages, as there are buttons missing (http://i.imgur.com/fFLtS90.png).

    Not sure what if this is issue of WordPress or Wedos.

    • This reply was modified 2 years, 4 months ago by  jirkadus. Reason: Adding screenshots links

    Hi, I´m having absolutely the same problem. I deactivated all plugins, re-activated them.
    Still, same error when trying to access all posts from admin backend.
    Then tried to update Wp to version 4.8 w/o any success.
    Dear support any advise?
    And we are also on wedos, seems to be a CZ prob, LOL

    Also my web is hosted at Wedos. I talked with their support and they said they have multiple reports from their customers with this problem and their technicians are looking at it. Let’s hope it get’s fixed soon.

    So Suddenly it started to work. I checked all 3 pages and on all of them, everything is fine now. I vill have a chat with wedos guys to get an idea of what to hack was wrong. I was about to modify the edit.php, LOL

    Howdy,
    Wedos installed a newer version of Apache and got some probs on mod_rewrite module. So they rolled back and probs are gon.

    i see… I hate these frustrating moments when trying to fix something I actually can’t. But I am glad that it has been now fixed and can confirm that.

    Yes, also started to work for me and I got the same explanation from Wedos.

    I also had the same problem on my local development system today after updating to Apache 2.4.26.
    There’s already a bug report for it.

    A quick fix, if you don’t have access to your webserver config, is to add a line in your .htaccess file:

    ProxyFCGIBackendType GENERIC

    According to the Apache 2.4.26 changelog they changed this setting to FPM and created this new setting to let server admins change it back to the old GENERIC value.

    @mrioia: ProxyFCGIBackendType GENERIC did not work for me but I was able to switch from FPM to FCGId because I run my own host. A big THANK YOU for this valuable info.

    THANK YOU!!

    It worked like a charm.

    Had this problem on my local machine and added ProxyFCGIBackendType GENERIC to my htaccess file and it worked.

    Thanks!

    Worked 100% as well. Thank you @mrioa!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Invalid post type on wp-admin/edit.php’ is closed to new replies.