Support » Plugins » Invalid Podcast Feed

  • I run a podcast at using PodPress. Everything was running fine until a few days ago when I started getting messages from subscribers that there was a problem with their subscriptions. I haven’t changed a thing but suddenly people are getting a message “American Freethought does not seem to be a valid Podcast URL”. Might this be a temporary glitch on iTunes’ end, or is there something else going on that I can fix?

Viewing 1 replies (of 1 total)
  • I have tried to subscribe to your podcast via the iTunes client software and it is possible but after the subscription I’m getting also such error message.

    I have looked also into the source code of the your podcast feed and it seems that your server does not deliver it completely. The code stops after the duration tag of episode 15 and there is no final </item>, </chanel> and </rss> tag wat makes this Feed not well formed.
    A possible explanation could be a time limit on your server. Server in general have usually a time limit for all kinds of script (e.g. max_execution_time). Maybe this time limit is to low for the script which builds your podcast Feed.
    Less likely is a memory limit for scripts.
    You may ask your provider how big(or small) these limits are and if it is possible to change them.

    But an easier solution might be the limitation of the number of posts in each Feed (see Settings > Reading > Syndication feeds show the most recent). In every case modifying temporarily this value is a good way to find out whether this is a time (or memory) limit related problem.
    maybe set this value back to the default value: 10 and validate the Feed again. If it validates, you can increase this value step by step.


Viewing 1 replies (of 1 total)
  • The topic ‘Invalid Podcast Feed’ is closed to new replies.