Support » Fixing WordPress » Invalid Permalink for one of the page

  • Hi,

    I noticed an invalid permalink http://www.xxx.com/sample-page/contact-us. But I don’t have sample-page in my entire blog. Maybe it was the default that come with the theme twenty-thirteen. All other links are find, i.e. correctly displaying the URL according to the permalink setting which is set as using “Post Names”.

    Typing http://www.xxx.com/contact-us will get redirect to http://www.xxx.com/sample-page/contact-us.

    If I try to edit the page, and try to edit the permalink, it will not allow me to edit /sample-page/.

    I also attempted to temporary not using the menu but it does not solve the problem.

    Changing the permalink to default, all the URL will display as http://www.xxx.com/?p=40 etc. I change back to Post Names and the affected page is still showing /sample-page/contact-us.

    I am new to this blogging and also this forum, if there is an answer already somewhere, kindly guide me to the right place.

    Thanks ahead for your help.

    Cheers,
    James

Viewing 5 replies - 1 through 5 (of 5 total)
  • Copy the content of the page trash it and delete it permanently and re publish it . That will work

    It is still showing the “error” URL after deleting it permanently and recreating a new one.

    Try this: Go to your Settings->Permalinks and select a permalink option and click save (even if its the same option that you currently have). This flushes out the URL routing in WordPress and it rebuilds it.

    Does this fix your URL problem?

    I tried that already but it does not resolve the issue.

    I also notice that even if I move this page out from the parent page, the problem persists.

    I went on to perform many try-and-eroor experiments…… including those mentioned above.

    Finally, I think (?) I get it working now. After many attempts, I notice if I change the parents to <Home> page under the PAGE option and at the same time change the position of the page (drag and drop) under the APPEARANCE > MENU option will cause this error. (not sure if you know what I am describing).

    So, I create a new page, do not change the Page Attribute, then go to Appearance > Menu and drag the new page to come under the <Home>, save. It works.

    I am happy with the result but yet not happy with it. This is because all other pages works fine except this page.

    I also notice that any new page created that I want to place under <Home> MUST NOT set the page attribute, otherwise, the permalink will end up xxx.com/sample-page/<page title>. Strange behaviour, hope someone can shed some lights….

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Invalid Permalink for one of the page’ is closed to new replies.