Support » Plugin: GA Google Analytics » Invalid path causing open_basedir restriction error

  • Resolved horizonit

    (@horizonit)


    Hi,

    I’m seeing this error on an number of sites hosting on the Windows IIS server.
    Running PHP 7.3.6, MySQL 8.0.13

    [09-Jun-2019 09:22:53 UTC] PHP Warning: is_readable(): open_basedir restriction in effect. File(D:\Plesk\Vhosts\domain.co.uk\httpdocs/wp-content/plugins/D:\Plesk\Vhosts\domain.co.uk\httpdocs\wp-content\plugins\ga-google-analytics/languages/ga-google-analytics-en_GB.mo) is not within the allowed path(s): (D:/Plesk/Vhosts/derbyshireforklifts.co.uk\;C:\Windows\Temp\) in D:\Plesk\Vhosts\domain.co.uk\httpdocs\wp-includes\l10n.php on line 649

    The path generated is invalid:
    D:\Plesk\Vhosts\domain.co.uk\httpdocs/wp-content/plugins/D:\Plesk\Vhosts\domain.co.uk\httpdocs\wp-content\plugins\ga-google-analytics/languages/ga-google-analytics-en_GB.mo”

    As you can see the drive letter is included twice.

    Any thoughts on how this can be resolved?

    Cheers
    Paul

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Not sure, but will be glad to investigate further and try to resolve any issue. Notes: the plugin uses standard WP tags wherever possible, so this could be related to a wider issue on Windows II2 or whatever. Also the issue could be incorrectly installed plugin, so something to try would be to reinstall fresh from scratch.

    Plugin Author Jeff Starr

    (@specialk)

    Hi @horizonit, I hope you got this sorted. It’s been awhile with no reply so gonna go ahead and mark this thread as resolved to help keep the forum organized. Feel free to post again with any further questions or feedback, Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Invalid path causing open_basedir restriction error’ is closed to new replies.