• Resolved whatsdd

    (@whatsdd)


    Hi,

    I have created a google shopping feed with attributes with a WordPress Plugins and it works. However, in the local inventory feed google asked for store code. I have already added a store code to my GMB account. Now, I want to add the same good to my feed in attributes Plugins. I will be very thankful if someone could help me how to add the store code in my feed. Thank you and Best Regards,

    Invalid or missing required attribute: store code
    Feed: https://billigetesterpro.no/wp-content/uploads/woo-feed/google_local_inventory/xml/local-inventory.xml
    Best Regards,
    Amy

    • This topic was modified 2 years, 3 months ago by whatsdd.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support ansarybadal

    (@ansarybadal)

    Hi @whatsdd

    You need to add the store code here – https://www.dropbox.com/s/bkb0yyji69f7le3/2022-04-19_13-05-33.png?dl=0

    Thank you,

    Hi,

    Please help, I have the same issue as above. I try to generate google local inventory feed. I already setup the store code in GMB and when generated feed I added store code in that place you showed on picture. After generating feed, store code doesn’t appear in xml file, it shows like this for every product:

    <item>
    <g:store_code/>
    <g:id>10660</g:id>
    <g:quantity>12</g:quantity>
    <g:price>75.00 USD</g:price>
    <g:sale_price/>
    <g:sale_price_effective_date/>
    <g:availability>in stock</g:availability>
    <g:pickup_method/>
    <g:pickup_sla/>
    </item>`

    I tried multiple times, istalled ctx feed version is the newest 4.4.60.
    Thank you in advance!

    Plugin Support ansarybadal

    (@ansarybadal)

    Hello @salwaz

    Can you please share a screenshot of the feed config? You can use pasteboard or Dropbox to share the screenshot.

    Thank you,

    Hi,

    First when I created the feed it was not adding store id, I tried to regenerate still didn’t work. Then I left it how it was and when it was automatically regenerated again next day it was already correct, in the xml file the items had store id as it should. So the bug is when someone creates the feed. Anyways, here is the link to the feed config:

    https://pasteboard.co/palso6Gd8pZS.jpg

    Thank you anyways

    Plugin Support ansarybadal

    (@ansarybadal)

    Hi @salwaz

    The possible reason could be feed caching. If you are using any caching plugin then please, exclude the feed directory from the caching plugin.
    Here you can find the instructions on how to exclude the plugins directory from a few most popular caching plugins.

    Thank you,

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Invalid or missing required attribute: store code’ is closed to new replies.