Support » Plugin: Google Tag Manager for WordPress » Invalid or missing account ID

  • Resolved markerx

    (@markerx)


    I have installed this plugin on numerous site in the past.

    I just installed this plugin on a new site, and Tag Assistant is showing the following error:

    Invalid or missing account ID

    I have tried the all three Container code placements, and I am not sure what to do next.

    The GTM code appears in the site’s source code.

    Any ideas?

    Thanks!!!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Same problem. My ID is added to your plugin and the Universal Analytics tag that I added to my Tag Manager is also working correctly.

    When I look at Tag Assistant, it appears that there are extra quotes…

    Screenshot of Tag Assistant

    Sorry for the confusing message above;

    – I have added my Account ID at the plugin.
    – Tag Assistant gives a ‘Invalid or missing account ID’ error on the Tag Manager code.
    – In my Tag Manager account I’ve added an Universal Analytics tag. This tag IS working and visitors are tracked.

    Hi everyone !

    I have exactly the same problem as @dvyss.

    I hope we’ll find a solution !

    Similar case here.

    I have 4 tags: 1 Analytics, 1 Remarketing, 2 AdWords.

    Both the Analytics and Remarketing tags are validated by the Tag Assistant.
    The 2 AdWords tags are shown as having an invalid account ID.

    Re. container code placement, I’ve tried ‘Foother of the page’ and ‘Codeless injection’, both fail with the same message.

    I’m facing the same problem too!

    Trying to debug the problem, I installed GTM codes manualy on a simple html website.

    There, Tag Analyzer also shows me the same error message.

    On this static website I am using a new container, on a new GTM account, copy codes from GTM and paste them where GTM sais they should go.

    I am starting to wonder if the problem could be somewhere else but the WP plugin

    Great observation Matus.

    Your post prompted me to look at a few other sites that I have installed this plugin on, and also use GTM.

    Google Tag Assistant works perfectly, without any errors, on these olde site.

    Then, I stumbled upon this post: https://plus.google.com/u/0/+SimoAhava/posts/WVSWfxpjScj?sfc=true

    Hey all, just wanted to share an additional false negative regarding Google Tag Manager and Google Tag Assistant. Many already know about the fact that Google Tag Assistant doesn’t recognize the new container snippet placement recommendation (JavaScript snippet in <head>).

    Another one is that if you have a new(ish) container, where the GTM-XXXXXX id has more than 6 Xs (e.g. GTM-5PKAMGS), Google Tag Assistant will complain about invalid Account ID, as it only treats container IDs of 4-6 characters as valid. You can ignore this warning, but you might want to check the Network tab of your browser developer tools that the gtm.js library has downloaded without error.

    Maybe those of ue getting errors are using newly create GTM containers?

    • This reply was modified 3 years, 2 months ago by markerx. Reason: typo

    That seems to be definetively my case, both codes that I am using are 7 characters long.

    Thanks for the research @markerx, will ignore the alert and run some tests to see what happens.

    Thanks, @markerx, I am getting that same error, but see that the gtm.js?id=GTM-XXXXXXX is getting downloaded. Will track my GA for the next couple days to ensure I’m not flat lining. 🙂

    I am not using this plugin. I directly edited child-theme’s file and still getting the error in Google Assistant Chrome Extention. 🙁 Probably this is a bug in Google Tag Manager itself. See this reference

    Did you folks ever check your google analytics debug messages? It looks like due to this ID issue, data is not being recorded… see my debug log below:

    analytics_debug.js:10 Tracking ID not set. Aborting hit.log @ analytics_debug.js:10O @ analytics_debug.js:9ya @ analytics_debug.js:29gc.H @ analytics_debug.js:24ad.send @ analytics_debug.js:57Y.b.(anonymous function) @ analytics_debug.js:38jf.R @ analytics_debug.js:68jf.H @ analytics_debug.js:65Z @ analytics_debug.js:68d @ gtm.js?id=GTM-XXXXXX:93_ua @ gtm.js?id=GTM-XXXXXX:97sf @ gtm.js?id=GTM-XXXXXX:33(anonymous function) @ gtm.js?id=GTM-XXXXXX:92ag @ gtm.js?id=GTM-XXXXXX:100jg @ gtm.js?id=GTM-XXXXXX:41a.push @ gtm.js?id=GTM-XXXXXX:106(anonymous function) @ (index):409each @ jquery.js?ver=1.12.4:2each @ jquery.js?ver=1.12.4:2(anonymous function) @ (index):397dispatch @ jquery.js?ver=1.12.4:3r.handle @ jquery.js?ver=1.12.4:3
    ga_debug.js:29 _gaq.push processing “gtmxxxxxx._set” for args: “[gtmid,GTM-XXXXXX]”:

    • This reply was modified 3 years, 1 month ago by arooni.
    Plugin Author Thomas Geiger

    (@duracelltomi)

    Hi Everyone,

    The solution is quite simple: Google Tag Assistant gives currently false positive messages on newly created GTM accounts. Those account have wider IDs: GTM-ABCDEFG (7 chars after GTM- prefix) which is not recognized correctly by Google Tag Assistant.

    You can continue working with the plugin and your GTM account, it will work fine.

    Have a great day,
    Thomas Geiger

    I’ve got the same problem but with this error some codes aren’t working such as Adwords Conversion Tracking and Facebook Pixel.

    Analytics and Adwords Remarketing it’s working fine.

    Plugin Author Thomas Geiger

    (@duracelltomi)

    Hi,

    If you see that other codes are firing from GTM than the GTM code itself should work as expected. Are you sure there is no misconfiguration inside your GTM container?

    Thomas

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Invalid or missing account ID’ is closed to new replies.