Support » Plugin: Simple Basic Contact Form » Invalid nonce value. Please try again” message

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author WPKube

    (@wpkube)

    Hi @stevethefootycoach

    Wanted to test it out but after submission got a Sucuri Firewall page saying access from my country is blocked (I’m from Serbia).

    Nonces are a WordPress security feature to make sure that a form submission comes from the site itself and not externally.

    I do see the form and do see the nonce field in there. Since it’s showing up in the hidden form field it’s also being submitted with the form.

    It’s not a custom implementation of a feature, it’s native WordPress functionality, so the only thing that comes to mind is that there might be a conflict with some other plugin.

    Can you send over a list of plugin you use?

    Thread Starter stevethefootycoach

    (@stevethefootycoach)

    Hi

    many thanks for the quick response.

    I’ll see if I can allow you full access to the form.

    In the meantime, here’s a list of my plugins:

    Autoptimize by Frank Goossens (futtta).
    Classic Editor by WordPress Contributors.
    Cookie Bar by Brontobytes.
    Cornerstone by Themeco.
    Disable REST API by Dave McHale.
    Favicon by RealFaviconGenerator by Philippe Bernard.
    Google Analytics for WordPress by MonsterInsights by MonsterInsights.
    LuckyWP Table of Contents by LuckyWP.
    NextGEN Gallery by Imagely.
    Plugins List by David Artiss.
    Rank Math SEO by Rank Math.
    Really Simple SSL by Rogier Lankhorst, Mark Wolters.
    Reviews for Schema by Magazine3.
    Schema & Structured Data for WP & AMP by Magazine3.
    Simple Basic Contact Form by WPKube.
    Strong Testimonials by MachoThemes.
    Sucuri Security – Auditing, Malware Scanner and Hardening by Sucuri Inc..
    Wonder PDF Embed by Magic Hills Pty Ltd.
    Wordfence Security by Wordfence.
    WP-Optimize – Clean, Compress, Cache by David Anderson, Ruhani Rabin, Team Updraft.
    WP Fastest Cache by Emre Vona.
    WPvivid Backup Plugin by WPvivid Team.
    X – Custom 404 by Themeco.

    By the way, I can always get the form to work the second time I click on submit. It’s just the first time that I get the error message.

    Thread Starter stevethefootycoach

    (@stevethefootycoach)

    I’ve unblocked Serbia. You should be able to use the form now.

    Plugin Author WPKube

    (@wpkube)

    Hi @stevethefootycoach

    I just tried it out and got the success message.

    Can you check if you received an email from me (the name I used was “Developer Test”).

    Thread Starter stevethefootycoach

    (@stevethefootycoach)

    Yes, I received it.

    When I test the form, (like just now) sometimes it goes first time.

    Sometimes it doesn’t.

    It’s hard to replicate.

    Are there any plugins in that list that you know might cause a problem for your form?

    Plugin Author WPKube

    (@wpkube)

    Hi @stevethefootycoach

    Maybe it’s because of the caching plugin.

    By default a WordPress nonce value is valid for 24 hours and then a new one gets generated. And it might be less, it’s possible that period is lowered by the security plugins you have but can’t say for sure.

    So if a nonce value expires and the cached version of the page still has that old nonce value it will show the error you are having since it’s no longer valid.

    Next time it happens can you try clearing the cache and then try the contact form again. If it works that’s the issue and we’ll figure something out to solve that.

    Thread Starter stevethefootycoach

    (@stevethefootycoach)

    I think that’s it.

    The form only gets used once every few days so an out of date nonce would probably trigger the ‘invalid nonce’ error.

    I will try to find a way to clear the page cache every day, automatically.

    That might fix it.

    If it happens again, I’ll let you know.

    Plugin Author WPKube

    (@wpkube)

    Hi @stevethefootycoach

    If the page is visited once every couple days it’s best to set that page to not be cached, should be an option to disable caching for specific URLs in WP Fastest Cache. If you need assistance with that let me know.

    Thread Starter stevethefootycoach

    (@stevethefootycoach)

    Hi

    thanks for that.

    I think I have disabled caching for that page!

    The page URL ends in /book-a-driving-lesson

    This is what I’ve done in WP Fastest Cache options:

    https://ibb.co/JWLMPGy

    Plugin Author WPKube

    (@wpkube)

    Hi,

    You’re welcome.

    Yeah, that should fix it. In case it happens again let me know and we’ll try and figure out what’s going on.

    Hello, allow me to speak on the subject. It is indeed an error related to caching. I use wprocket and the contact page is excluded from caching.The nonce error did not occur again.

    Regards

    Thread Starter stevethefootycoach

    (@stevethefootycoach)

    Thanks ms06!

    Plugin Author WPKube

    (@wpkube)

    Thanks.

    I’ll mark this ticket as resolved.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Invalid nonce value. Please try again” message’ is closed to new replies.