WordPress.org

Support

Support » Plugins and Hacks » Loco Translate » [Resolved] Invalid MO format

[Resolved] Invalid MO format

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author timwhitlock

    @timwhitlock

    What software generated the MO file?

    Loco will only read a MO file if it can’t find a corresponding PO file.

    Ok, that’s a good question 🙂

    Actually the theme is out of the box, and when I look into the dir tree, I can’t see any .mo file.

    Plugin Author timwhitlock

    @timwhitlock

    I don’t know why it would read a MO file without the .mo extension.
    What theme is it?

    The theme is Codilight.

    In File system permissions for Codilight , I can see a :
    themes/codilight/default.po

    Do I need to generate to .mo from this file ?

    Plugin Author timwhitlock

    @timwhitlock

    This is a pay-for theme, so I can’t try it without buying.

    Generating a MO file from the PO is not your issue. Loco won’t try to read a MO file unless there is no PO file. You’re saying it’s already trying to read a MO file and failing. I need to work out why that is. If you can send me the theme I will check if there is a problem.

    Plugin Author timwhitlock

    @timwhitlock

    Have you managed to resolve your issue?

    Please note a new version has been published since this ticket was opened (1.4.6)

    It’s OK.
    I manage this by translating the PO mannualy.

    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Invalid MO format’ is closed to new replies.
Skip to toolbar