WordPress.org

Support

Support » How-To and Troubleshooting » Invalid method in request

Invalid method in request

  • Hi, I recently installed WordPress on an old G3 iMac running Mac OS X Server (10.4.7). Everything seems to function, but the web based admin console is VERY slow. Delays of several minutes are not uncommon when saving a post/page. If I use a client tool, such as MarsEdit then the delay when updating content is imperceptible.

    The Apache error log shows many “Invalid method in request” errors, these are always clustered around the same point in time for the same client. Here’s an example: –

    [Fri Aug 25 16:40:28 2006] [error] [client 10.0.1.253] Invalid method in request
    [Fri Aug 25 16:40:28 2006] [error] [client 10.0.1.253] Invalid method in request
    [Fri Aug 25 16:40:28 2006] [error] [client 10.0.1.253] Invalid method in request
    [Fri Aug 25 16:40:28 2006] [error] [client 10.0.1.253] Invalid method in request
    [Fri Aug 25 16:40:28 2006] [error] [client 10.0.1.253] Invalid method in request
    [Fri Aug 25 16:40:28 2006] [error] [client 10.0.1.253] Invalid method in request
    [Fri Aug 25 16:40:28 2006] [error] [client 10.0.1.253] Invalid method in request
    [Fri Aug 25 16:40:28 2006] [error] [client 10.0.1.253] Invalid method in request
    [Fri Aug 25 16:40:28 2006] [error] [client 10.0.1.253] Invalid method in request
    [Fri Aug 25 16:40:28 2006] [error] [client 10.0.1.253] Invalid method in request
    [Fri Aug 25 16:40:28 2006] [error] [client 10.0.1.253] Invalid method in request
    [Fri Aug 25 16:43:38 2006] [error] [client 10.0.1.253] Invalid method in request

    Are these errors anything to worry about? Could they be indicative of the performance issues?

    Hope someone can offer some good advice!

    Cheers, Steve

Viewing 3 replies - 1 through 3 (of 3 total)
  • Most slow/timeout issues when posting are due to Update Services (Options:Misc) being pinged and timing out or responding very slowly.

    Test by removing all/any services listed there…

    Hi, Thanks for replying. The only options I have in are “Track Links’ Update Times” and “Use legacy my-hacks.php” file (and a couple of uploading options), neither of which are selected. Is this what you meant?

    Nope, I screwed up. Take a look in the box near the bottom of Options:Writing called “Update Services”…

    Sorry.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Invalid method in request’ is closed to new replies.