Support » Plugin: LH Add Media From Url » Invalid Link

  • TKList


    Add Media from URL
    Error: Invalid Link

    Keep getting this error
    Even with https and using different urls.

Viewing 7 replies - 1 through 7 (of 7 total)
  • kyoshiromibu


    The image is either from Photon or has more than one period in the image name. Somebody else reported this over 9 months ago in a previous topic, but no resolution yet.

    I’m experiencing the same issue.

    Plugin Author shawfactor


    Can you let me know some example of the urls you have had issues with and I will test. Noting I tested a photon url just then and it worked fine…

    • This reply was modified 7 months, 4 weeks ago by  shawfactor.
    Plugin Author shawfactor



    the first works fine, see example here:

    the second kicked off this error when I tried to upload it from a URL:

    Type: PHP Fatal error Line: 352
    File: /home/melbour9/public_html/wp-includes/class-wp-image-editor-imagick.php

    the actual file is uploaded:

    but thiz just means that all the thumbnails have not been generated, I´m 90% sure that is jst because the underlying file size is massive!

    Do you have any other urls that you have problems with?

    Note this really is a bit dependent on your hosting setup too


    I get the same error on both “Invalid Link”, what could it be on my end that would cause that?

    ### Begin System Infos (Generated 2018-11-26 00:20:25) ###
    ———— SITE INFO
    Site URL:
    Home URL:
    Multisite: No

    Platform: Windows
    Browser Name: Chrome
    Browser Version: 70.0.3538.110

    WP Version: 4.9.8
    Language: en_US
    Permalink Structure: /%year%/%monthnum%/%day%/%postname%/
    Active Theme: Customizr 4.1.22
    Show On Front: posts
    ABSPATH: /home2/twovnews/public_html/
    WP_DEBUG: Disabled
    WP Memory Limit: 1024MB

    Version: 1.3.0
    Upgraded From: 1.2.2
    Started With: 1.1.8

    ———— MU PLUGINS
    Endurance Page Cache: 1.2

    Autoset Featured Image: 1.2.2
    Better Search Replace: 1.3.2
    Cloudflare: 3.3.2
    CloudFlare Flexible SSL: 1.2.2
    Comments Evolved for WordPress: 1.6.3
    Cookie Notice: 1.2.44
    Disable Emojis (GDPR friendly): 1.7.2
    Glue for Yoast SEO & AMP: 0.4.3
    Head, Footer and Post Injections: 3.1.2
    HTTP Headers: 1.10.5
    iThemes Security: 7.2.0
    Jetpack by 6.7
    LH Add Media from URL: 1.15
    NextScripts: Social Networks Auto-Poster: 4.2.8
    Nimble Builder: 1.3.0
    Official StatCounter Plugin: 2.0.6
    Post Snippets: 3.0.5
    Quick Featured Images: 13.3.2
    Really Simple SSL: 3.1.2
    Share Buttons by AddThis: 6.1.8
    Smush: 2.9.1
    Title to Terms Ultimate: 4.0
    W3 Total Cache: 0.9.7
    WP-Optimize: 2.2.6
    WP-Sweep: 1.0.12
    WPSSO Core [Main Plugin]: 4.17.0
    Yoast SEO: 9.2.1

    AMP: 0.7.2
    Image Cleanup: 1.9.2
    LiveSupporti: 1.0.6
    Media Deduper: 1.4.2
    Pin It Button for Pinterest: 1.0
    Regenerate Thumbnails: 3.0.2

    PHP Version: 7.2.12
    MySQL Version: 5.6.41
    Webserver Info: Apache

    ———— PHP CONFIG
    Memory Limit: 2048M
    Upload Max Size: 256M
    Post Max Size: 512M
    Upload Max Filesize: 256M
    Time Limit: 600
    Max Input Vars: 2000
    Display Errors: On (1)
    PHP Arg Separator: &
    PHP Allow URL File Open: 1

    ### End System Infos ###

    • This reply was modified 7 months, 3 weeks ago by  TKList.
    • This reply was modified 7 months, 3 weeks ago by  TKList.
    Plugin Author shawfactor



    I have a new version of the plugin that may solve your issues, basically it is a complete rewrite (and an improvment I think).

    I am however reluctant to release it yet. I´ll work out branching on svn and send you a link from where you can download the beta version shortly.


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Invalid Link’ is closed to new replies.