Support » Fixing WordPress » Invalid Line in RSS Feed?

  • Resolved Servant

    (@servant)


    Every news reader I’ve tried yields an error trying to process the feed from http://logoswalk.com/journal/wp-rss2.php. When they send it through feedvalidator.org I’m presented with the following message:

    This feed does not validate.
    line 1, column 0: Undefined root element: meta
    <meta http-equiv=”content-type” content=”text/html;charset=iso-8859-1″>
    line 2, column 0: XML parsing error: <unknown>:2:0: xml declaration not at start of external entity [help]
    <?xml version=”1.0″ encoding=”utf-8″?>

    Doesn’t this mean that line 1 should not exist? When I look at other sites’ wp-rss2.php files, THEIR line 1 is my line 2 and I’m not seeing my line 1 in any of their files.

    How do I correct this? What do I need to change to eliminate the generation of line 1? Or am I just completely way off here?

Viewing 5 replies - 1 through 5 (of 5 total)
  • skippy

    (@skippy)

    Is this a stock installation of WordPress 1.5?

    The <meta … > line ought not be there. If you’ve edited any files, you may need to un-edit them.

    Servant

    (@servant)

    This was installed by my host provider via Fantastico. I can make changes to any files necessary…would you happen to know what I should change?

    Thanks!

    skippy

    (@skippy)

    Alas, I’m not sure exactly where that error may be generated. Check wp-rss2.php, just to be sure.

    Moderator James Huff

    (@macmanx)

    See: http://feedvalidator.org/check.cgi?url=http%3A%2F%2Flogoswalk.com%2Fjournal%2Fwp-rss2.php

    Have you added meta data to your RSS file? If not, disable all plugins and check again.

    Servant

    (@servant)

    YOU…DA…MAN!!! Disabling my plug-ins immediatly brought the RSS feeds online. I re-activated them 1 at a time and found a mis-behaving one which I re-downloaded, re-installed, and now everything’s BE-YOO-TEE-FULL. Thanks for ending nearly 2 weeks of angst and groping, macmanx.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Invalid Line in RSS Feed?’ is closed to new replies.