Support » Plugin: Contact Form With Captcha » invalid-json error

Viewing 5 replies - 1 through 5 (of 5 total)
  • Yes, I am receiving the same message:

    “Something went wrong

    The following error was returned: invalid-json

    Check the error code reference at https://developers.google.com/recaptcha/docs/verify#error-code-reference.

    Note: Error code missing-input-response may mean the user just didn’t complete the reCAPTCHA.”

    would love to have a fix for this ASAP…
    according to google the error codes could be

    Error code reference
    Error code Description
    missing-input-secret The secret parameter is missing.
    invalid-input-secret The secret parameter is invalid or malformed.
    missing-input-response The response parameter is missing.
    invalid-input-response The response parameter is invalid or malformed.

    thanks in advance, -Rick

    Plugin Author Technology Blog

    (@zackhasit)

    Please try on another site and see if issues persists. I have one blog : http://www.teqlog.com which is running everything ok on latest versions for WP and plugins. I cant fix it unless I see it broken on my site where I have full debugging privileges.

    Teqlog,

    thanks for the reply.

    I have attempted to update ‘Contact Form With Captcha’ plugin on at least 3 different sites with version 1.6.2 and they all fail in this way: the new captcha installs properly, the public and private keys work, and the captcha displays the ‘I am not a robot’ check box as expected. HOWEVER, the plugin does not instantiate the subsequent series of images that the user must select to complete the captcha. Since there are no images that display, nothing gets selected and the captcha fails with ‘missign input response’ error.

    Please note that version 1.6.1 of the plugin is still working properly on some of my installs (e.g. lessson.rickrichbourg.com); but, I have had to move to another option at least temporarily to make page owners happy.

    Lastly, please note that EVEN ON YOUR CONTACT page I have experienced similar behavior (using Firefox 39.0.3): when checking the ‘I am not a robot’ (for the first time) the check box appears; but, NO IMAGES pop up to select from! =:o I have also noticed that after checking the check box and no input is send I eventually get the “Verification expired. Check the checkbox again.” error from the Google captcha widget. Upon checking the checkbox again, I am THEN presented with a selection of images to satisfy the captcha challenge…

    Hopefully, I have explained this clearly enough and would be happy to discuss further… I really do appreciate this plug in.

    again thanks for your reply.

    best regards, -Rick

    I am also getting the same issue

    Something went wrong
    The following error was returned: invalid-json
    Check the error code reference at https://developers.google.com/recaptcha/docs/verify#error-code-reference.
    Note: Error code missing-input-response may mean the user just didn’t complete the reCAPTCHA.
    Incorrect Captcha!

    Hi i am getting the same error :
    The following error was returned: invalid-json

    Check the error code reference at https://developers.google.com/recaptcha/docs/verify#error-code-reference.

    Note: Error code missing-input-response may mean the user just didn’t complete the reCAPTCHA.

    I am hosting on domain.com the site :http://www.wavetech3d.com/contact-us/

    any ideas what to do?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘invalid-json error’ is closed to new replies.