Support » Plugin: Better File Editor » invalid header error in wordpress 4.0

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Bryan Petty

    (@bpetty)

    Could you please explain how and where you’ve seen this error?

    What were you doing?
    What page were you on?
    Any other plugins installed?

    I’m getting this error also. It happened just after downloading and then pressing the activate button. Activation was possible from the plugin page, but the editor only seems to be showing up in the theme editor… which is not a problem, but it would be neat to also get it in the page and post edit views.

    Plugin Author Bryan Petty

    (@bpetty)

    Invalid header errors is a symptom of having ‘display_errors’ turned on in your PHP configuration, and either WordPress or the plugin generated an error before displaying the page. That’s normal, but I really can’t help unless you can show me the actual error, or you give me more details about your configuration like version of PHP, WordPress version, and I’m able to reproduce it.

    Also please note that the plugin was never designed to replace the page and post editors, just the theme and plugin editors. Also see:
    https://wordpress.org/support/topic/hook-into-pagepost-html-editor?replies=5

    Same here. Invalid header error after downloading and immediately activating the plugin. Using WP 4.1 with a bunch of plugins (which in itself is a warning sign I guess). PHP is version 5.5.18. No errors found in web server log files. Also, display_errors=off in my php.ini. The plugin works when later activated through the regular plugin page. So I’m happy and not looking for additional support. I just wanted to confirm the same issue that others had here. Thanks for a great plugin! Very useful!

    Plugin Author Bryan Petty

    (@bpetty)

    I think I figured out why this is occasionally happening. The latest release somehow managed to duplicate the development branch release along with the latest stable tag, so there were two copies of the plugin in the latest release.

    I’ve removed the duplicate copy now. I was able to finally reproduce the problem, and it no longer appears to be an issue.

    Great news! Thanks for checking this out!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘invalid header error in wordpress 4.0’ is closed to new replies.