Support » Plugin: WP RSS Aggregator – News Feeds, Autoblogging, Youtube Video Feeds and More » [NSFW] Invalid feed URL on long-established soruce

  • Resolved SeattleLion

    (@seattlelion)


    The most recent post from a blog I list in my sidebar didn’t appear. When I went to the feed source listing, I got the invalid feed URL message. I clicked the validate feed link and received a valid feed message. However, it also said that there was a potential issue for some readers. (See link above) My site (the target of the link) is a standard WordPress site. I’ve made no code modifications to it and I don’t understand what’s causing this problem. I tried the Forced Feed option and still got the same error message. What can I do?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’m getting similar for feeds that SHOULD work.

    I wonder what is going on with this thing?

    I validate the feeds but the plugin thinks they are no good and can’t seem to fetch the feed or display it so I have these big empty blocks on my aggregator blog…

    Frustrating.

    whatsupmf

    (@whatsupmf)

    I’m having same issue where validator says it’s valid but plugin gives me the red exclamation point… e.g. https://validator.w3.org/feed/check.cgi?url=https://www.eckerd.edu/news/blog/category/alerts/feed/

    Thread Starter SeattleLion

    (@seattlelion)

    Apparently, no one from the development team cares! I’ve made this request weeks ago.

    Plugin Author Mark Zahra

    (@markzahra)

    Hi folks, please open separate support threads individually as your issues may very well be caused by different things.

    @seattlelion have you tried the possible solutions on this page? https://kb.wprssaggregator.com/category/80-feed-items-or-posts-not-importing – if not, please have a look through them as they typically solve the majority of similar issues.

    @worlok please open a separate thread and provide us with the RSS feeds that are having this problem. If you’re using any premium add-ons, please use the contact form on our website.

    @whatsupmf likewise, please open a separate thread. Before opening that thread through, do hover over the red exclamation mark and let us know what error is shown there. It should tell us exactly what’s going on.

    Thread Starter SeattleLion

    (@seattlelion)

    There is no exclamation point. This is the message I get on the feed page:
    Invalid feed URL – Double check the feed source URL setting above.

    This message appears on the right side. I tried the “force-feed” setting with no change. I reviewed all of the items you referred to in the link you supplied. None of them apply to this problem. If you look at my original message, you will see a link to the feed. This is the service you provide the link for on the feed source page. It shows that there is an issue with my feed but also says the feed is valid. This feed has been working fine for several months with no issues. Suddenly, a few weeks ago RSS Aggregator start started throwing this message. Please check the validation page link I provided. It should give you an idea what’s wrong. All the other feeds I am aggregating are performing correctly. Apparently, this isn’t just my issue.

    Thread Starter SeattleLion

    (@seattlelion)

    I solved the problem. The root certificate from Comodo expired on May 31. This was not easily detected, but RSS aggregator sort of picked it up without clearly identifying the problem. A cURL error 60 which the plugin cited is too vague. Anyway, my ISP got me the new CACert with an updated root and all is well.

    Thanks for your time.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[NSFW] Invalid feed URL on long-established soruce’ is closed to new replies.