Support » Plugin: Publish To Apple News » INVALID DOCUMENT error

  • Resolved donniebaseball


    Trying to publish, this is the error I’m getting:

    There has been an error with the API. Please make sure your API settings are correct and try again: INVALID_DOCUMENT

    No idea what the issue is. All the API key information is correct.

    Yes, there’s a Featured Image
    Yes, there’s one additional image in the document
    Remote images = yes

    JSON file =

    I’ve tried publishing with and without images, neither works so that’s not the issue. Any ideas? There’s a lot of formatting parameters in the settings, is that causing errors? About to give up on the plugin and switch to RSS. There are no additional error logs to review.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Bradford Campeau-Laurion


    Have you used the News Preview tool to debug your content? That’s the best way to find out the source of an INVALID_DOCUMENT error.

    Figured it out with the Preview debugger. The error is with a poll plugin.

    It’s the most popular plugin on WP. Until it’s supported, best course of action is:

    1. Publish the article without the poll on WP
    2. Wait for article to publish to Apple News
    3. Insert poll
    4. Live with the fact there’s an Invalid Document error when updating

    Not ideal but at least it works.

    Plugin Author Bradford Campeau-Laurion


    There are dozens of filter hooks in the plugin to edit your content or to disable plugins before publishing. A little bit of code can fix this more smoothly.

    There absolutely no way to model a poll in Apple News so it’s perfectly valid that it would cause an error. Also, whether or not that plugin is popular, there are thousands of plugins and we can’t guarantee compatibility with them all, nor favor certain ones because of their popularity.


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘INVALID DOCUMENT error’ is closed to new replies.