Support » Plugin: Duplicator - WordPress Migration Plugin » 'Invalid default value' = database install fail

  • Resolved david1103

    (@david1103)


    hello, i used to use this plugin with 100% success on my localhost until i updated my WAMP install to the new 3.01 version that has all the latest versions of PHP etc.

    Now when I try to create the site on my local host I get the errors below and can’t even log into the new site. Really need some help! THANKS! (I just copied what I thought was relevant)

    **********************************************************************
    VERSION: 1.1.0
    PHP: 7.0.2 | SAPI: apache2handler
    SERVER: Apache/2.4.17 (Win64) PHP/7.0.2
    **********************************************************************
    **********************************************************************
    DATABASE-ROUTINES
    **********************************************************************
    ————————————–
    SERVER ENVIROMENT
    ————————————–
    MYSQL VERSION: 5.7.9
    TIMEOUT: 5000
    MAXPACK: 1048576
    ————————————–
    DATABASE RESULTS
    ————————————–
    **ERROR** database error write ‘Invalid default value for ‘comment_date” – [sql=
    CREATE TABLE wp_comments (
    comment_ID bigint(20) unsigned NOT NULL A…]
    **ERROR** database error write ‘Invalid default value for ‘created” – [sql=
    CREATE TABLE wp_duplicator_packages (
    id bigint(20) unsigned NOT NUL…]
    **ERROR** database error write ‘Invalid default value for ‘link_updated” – [sql=
    CREATE TABLE wp_links (
    link_id bigint(20) unsigned NOT NULL AUTO_IN…]
    **ERROR** database error write ‘Invalid default value for ‘post_date” – [sql=
    CREATE TABLE wp_posts (
    ID bigint(20) unsigned NOT NULL AUTO_INCREME…]
    **ERROR** database error write ‘Invalid default value for ‘user_registered” – [sql=
    CREATE TABLE wp_users (
    ID bigint(20) unsigned NOT NULL AUTO_INCREME…]
    **ERROR** database error write ‘Table ‘ne.wp_duplicator_packages’ doesn’t exist’ – [sql=

    /* INSERT TABLE DATA: wp_duplicator_packages */
    INSERT INTO `wp_duplicato…]
    **ERROR** database error write ‘Table ‘ne.wp_duplicator_packages’ doesn’t exist’ – [sql=INSERT INTO wp_duplicator_packages VALUES(“2”, “20151126_naturalexpressio…]
    **ERROR** database error write ‘Table ‘ne.wp_duplicator_packages’ doesn’t exist’ – [sql=INSERT INTO wp_duplicator_packages VALUES(“3”, “20151126_naturalexpressio…]
    **ERROR** database error write ‘Table ‘ne.wp_posts’ doesn’t exist’ – [sql=
    /* INSERT TABLE DATA: wp_posts */
    INSERT INTO wp_posts VALUES(“4”, “1”, …]
    **ERROR** database error write ‘Table ‘ne.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“5”, “1”, “2015-09-07 14:22:39”, “2015-09-07 …]
    **ERROR** database error write ‘Table ‘ne.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“7”, “1”, “2015-09-07 14:30:51”, “2015-09-07 …]
    **ERROR** database error write ‘Table ‘ne.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“8”, “1”, “2015-09-07 14:32:08”, “2015-09-07 …]
    **ERROR** database error write ‘Table ‘ne.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“9”, “1”, “2015-09-07 14:32:36”, “2015-09-07 …]
    **ERROR** database error write ‘Table ‘ne.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“10”, “1”, “2015-09-07 14:33:05”, “2015-09-07…]
    **ERROR** database error write ‘Table ‘ne.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“11”, “1”, “2015-09-07 14:34:39”, “2015-09-07…]
    **ERROR** database error write ‘Table ‘ne.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“19”, “1”, “2015-09-09 08:33:24”, “2015-09-09…]

    … and this continues with Errors: Deploy (121)

    https://wordpress.org/plugins/duplicator/

Viewing 8 replies - 16 through 23 (of 23 total)
  • Hi, great plugin. I have a few questions…

    1. Any thoughts on having the sql mode on “disabled” by default?
    2. Does this issue get enough attention for it to be the default?
    3. What are the benefits of having the sql mode on “default”, compared to “disable”?

    In my opinion, if it was “disabled” by default, I wouldn’t have to google about how to fix my issue and I didn’t know that the solution was already in the plugin.

    @corylamleorg Just wanted to give you a heads up…

    I tested duplicator and I loved it, saw what the duplicator pro can do and bought it immediately as I can see its value for the long term.

    The only problem is, “disabled” sql mode is not available on the pro version.

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @vernardluz,

    Thanks for the feedback! We do have plans on integrating this up into the Pro version soon. We just had a version release with Pro that has a new architecture for the installer so we are letting it bake for just a bit. We should be adding this feature up into pro shortly…

    Thanks

    Thank you very much for posting this. I was able to fix it with your solutions.

    Thx, I had this problem on my wamp 3 too!

    Thank you for this tip!
    Now the duplicator tool is working for me too!!!

    Thanks for the tip I’ve just had this issue appear out of nowhere with WAMP. Adding

    [mysqld]
    port = 3306
    sql_mode=NO_ENGINE_SUBSTITUTION

    at the end and restarting did the trick.

    Hello to all.
    So, i had this error in the past but now my problem is a little different.
    Here is my 1st problem that was solved by @corylamleorg
    https://wordpress.org/support/topic/duplicate-from-ubuntu-to-xxserver/#post-8247633

    Now my 2nd problem.
    I want to duplicate from Ubuntu 16.04 to Ubuntu 14.04
    I have olso change sql_mode=NO_ENGINE_SUBSTITUTION
    The duplicate process was with version Developer 1.2.0, and the new version of Duplicator 1.2.15 but @corylamleorg what you wrote is not available anymore, i cannot find it. Here is what you wroted to me:
    ” On the installer under advanced options step 1 is a new checkbox labeled “Run this session with MySQL sql_mode disabled”. Check that box and then check the intaller-log.txt files to see if the SQLMODE value is set to NOT_SET. Of course you will need to make sure that NO_ENGINE_SUBSTITUTION is on in your my.ini and you recycled the mysql server.”

    Here is my errors:

    File timestamp is ‘Current’ mode: 2017-07-26 12:51:09
    <<< EXTRACTION COMPLETE: true

    WEB SERVER CONFIGURATION FILE RESET:
    – Backup of .htaccess/web.config made to *.170726125109.orig
    – Reset of .htaccess/web.config files

    STEP-1 COMPLETE @ 12:51:09 – RUNTIME: 0.9459 sec.

    ********************************************************************************
    * DUPLICATOR-LITE: INSTALL-LOG
    * STEP-2 START @ 12:51:31
    * NOTICE: Do NOT post to public sites or forums
    ********************************************************************************
    ————————————–
    DATABASE ENVIRONMENT
    ————————————–
    MYSQL VERSION: This Server: 5.5.57 — Build Server: 5.6.35
    FILE SIZE: database.sql (2.62MB) – installer-data.sql (2.62MB)
    TIMEOUT: 5000
    MAXPACK: 16777216
    SQLMODE: NO_ENGINE_SUBSTITUTION
    NEW SQL FILE: [/var/www/html/www.mydomain.com/installer-data.sql]
    DATABASE RESULTS
    ————————————–
    **ERROR** database error write ‘Unknown collation: ‘utf8mb4_unicode_520_ci” – [sql=
    CREATE TABLE wp_commentmeta (
    meta_id bigint(20) unsigned NOT NULL A…]
    **ERROR** database error write ‘Unknown collation: ‘utf8mb4_unicode_520_ci” – [sql=
    CREATE TABLE wp_comments (
    comment_ID bigint(20) unsigned NOT NULL A…]
    **ERROR** database error write ‘Unknown collation: ‘utf8mb4_unicode_520_ci” – [sql=
    CREATE TABLE wp_links (
    link_id bigint(20) unsigned NOT NULL AUTO_IN…]
    **ERROR** database error write ‘Unknown collation: ‘utf8mb4_unicode_520_ci” – [sql=
    CREATE TABLE wp_options (
    option_id bigint(20) unsigned NOT NULL AUT…]
    **ERROR** database error write ‘Unknown collation: ‘utf8mb4_unicode_520_ci” – [sql=
    CREATE TABLE wp_postmeta (
    meta_id bigint(20) unsigned NOT NULL AUTO…]
    **ERROR** database error write ‘Unknown collation: ‘utf8mb4_unicode_520_ci” – [sql=
    CREATE TABLE wp_posts (
    ID bigint(20) unsigned NOT NULL AUTO_INCREME…]
    **ERROR** database error write ‘Unknown collation: ‘utf8mb4_unicode_520_ci” – [sql=
    CREATE TABLE wp_term_relationships (
    object_id bigint(20) unsigned N…]
    **ERROR** database error write ‘Unknown collation: ‘utf8mb4_unicode_520_ci” – [sql=
    CREATE TABLE wp_term_taxonomy (
    term_taxonomy_id bigint(20) unsigned…]
    **ERROR** database error write ‘Unknown collation: ‘utf8mb4_unicode_520_ci” – [sql=
    CREATE TABLE wp_termmeta (
    meta_id bigint(20) unsigned NOT NULL AUTO…]
    **ERROR** database error write ‘Unknown collation: ‘utf8mb4_unicode_520_ci” – [sql=
    CREATE TABLE wp_terms (
    term_id bigint(20) unsigned NOT NULL AUTO_IN…]
    **ERROR** database error write ‘Unknown collation: ‘utf8mb4_unicode_520_ci” – [sql=
    CREATE TABLE wp_usermeta (
    umeta_id bigint(20) unsigned NOT NULL AUT…]
    **ERROR** database error write ‘Unknown collation: ‘utf8mb4_unicode_520_ci” – [sql=
    CREATE TABLE wp_users (
    ID bigint(20) unsigned NOT NULL AUTO_INCREME…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=
    /* INSERT TABLE DATA: wp_options */
    INSERT INTO wp_options VALUES(“1”, “…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“7”, “start_of_week”, “1”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“8”, “use_balanceTags”, “0”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“9”, “use_smilies”, “1”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“10”, “require_name_email”, “1”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“11”, “comments_notify”, “1”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“12”, “posts_per_rss”, “10”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“13”, “rss_use_excerpt”, “0”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“14”, “mailserver_url”, “mail.example.com”,…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“15”, “mailserver_login”, “login@example.co…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“16”, “mailserver_pass”, “password”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“17”, “mailserver_port”, “110”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“18”, “default_category”, “1”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“19”, “default_comment_status”, “open”, “ye…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“20”, “default_ping_status”, “open”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“21”, “default_pingback_flag”, “1”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“22”, “posts_per_page”, “10”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“23”, “date_format”, “j F Y”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“24”, “time_format”, “G:i”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“25”, “links_updated_date_format”, “j F Y G…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“26”, “comment_moderation”, “0”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“27”, “moderation_notify”, “1”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“28”, “permalink_structure”, “/%postname%/”…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“29”, “rewrite_rules”, “a:109:{s:34:\”sitem…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“30”, “hack_file”, “0”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“31”, “blog_charset”, “UTF-8”, “yes”)…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_options’ doesn’t exist’ – [sql=INSERT INTO wp_options VALUES(“32”, “moderation_keys”, “”, “no”)…]
    /* INSERT TABLE DATA: wp_posts */
    INSERT INTO wp_posts VALUES(“5”, “1”, …]
    **ERROR** database error write ‘Table ‘cartoonline.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“6”, “1”, “2017-01-04 16:29:39”, “2017-01-04 …]
    **ERROR** database error write ‘Table ‘cartoonline.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“7”, “1”, “2017-01-04 16:30:00”, “2017-01-04 …]
    **ERROR** database error write ‘Table ‘cartoonline.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“9”, “1”, “2017-01-05 10:27:05”, “2017-01-05 …]
    **ERROR** database error write ‘Table ‘cartoonline.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“10”, “1”, “2017-01-05 10:27:10”, “2017-01-05…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“11”, “1”, “2017-03-20 10:34:25”, “0000-00-00…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“12”, “1”, “2017-01-05 10:28:32”, “2017-01-05…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“13”, “1”, “2017-01-05 11:27:27”, “2017-01-05…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“14”, “1”, “2017-01-05 11:27:59”, “2017-01-05…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“15”, “1”, “2017-01-05 11:28:53”, “2017-01-05…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“16”, “1”, “2017-03-20 10:49:37”, “2017-03-20…]
    **ERROR** database error write ‘Table ‘cartoonline.wp_posts’ doesn’t exist’ – [sql=INSERT INTO wp_posts VALUES(“17”, “1”, “2017-01-05 11:30:15”, “2017-01-05…]
    /* INSERT TABLE DATA: wp_users */
    INSERT INTO wp_users VALUES(“1”, “cart…]
    ERRORS FOUND: 721
    TABLES DROPPED: 0
    QUERIES RAN: 2207

    wp_duplicator_packages: (1)
    wp_wfBadLeechers: (0)
    wp_wfBlockedIPLog: (34)
    wp_wfBlocks: (34)
    wp_wfBlocksAdv: (0)
    wp_wfConfig: (173)
    wp_wfCrawlers: (5)
    wp_wfFileMods: (0)
    wp_wfHits: (1632)
    wp_wfHoover: (0)
    wp_wfIssues: (1)
    wp_wfKnownFileList: (0)
    wp_wfLeechers: (5)
    wp_wfLockedOut: (0)
    wp_wfLocs: (2)
    wp_wfLogins: (274)
    wp_wfNet404s: (0)
    wp_wfNotifications: (3)
    wp_wfPendingIssues: (0)
    wp_wfReverseCache: (5)
    wp_wfSNIPCache: (1)
    wp_wfScanners: (2)
    wp_wfStatus: (8)
    wp_wfThrottleLog: (0)
    wp_wfVulnScanners: (0)

    Removed ‘2’ cache/transient rows

    CREATE/INSTALL RUNTIME: 0.3139 sec.
    STEP-2 COMPLETE @ 12:51:31 – RUNTIME: 0.3262 sec.

    ********************************************************************************
    * DUPLICATOR-LITE: INSTALL-LOG
    * STEP-3 START @ 12:51:34
    * NOTICE: Do NOT post to public sites or forums
    ********************************************************************************
    CHARSET SERVER: latin1
    CHARSET CLIENT: utf8
    ————————————–
    SERIALIZER ENGINE
    [*] scan every column
    [~] scan only text columns
    [^] no searchable columns
    ————————————–
    wp_duplicator_packages^ (0)
    wp_wfBadLeechers^ (0)
    wp_wfBlockedIPLog~ (34)
    wp_wfBlocks~ (34)
    wp_wfBlocksAdv^ (0)
    wp_wfConfig~ (173)
    wp_wfCrawlers~ (5)
    wp_wfFileMods^ (0)
    wp_wfHits~ (1632)
    wp_wfHoover^ (0)
    wp_wfIssues~ (1)
    wp_wfKnownFileList^ (0)
    wp_wfLeechers~ (5)
    wp_wfLockedOut^ (0)
    wp_wfLocs~ (2)
    wp_wfLogins~ (274)
    wp_wfNet404s^ (0)
    wp_wfNotifications~ (3)
    wp_wfPendingIssues^ (0)
    wp_wfReverseCache~ (5)
    wp_wfSNIPCache~ (1)
    wp_wfScanners~ (2)
    wp_wfStatus~ (8)
    wp_wfThrottleLog^ (0)
    wp_wfVulnScanners^ (0)
    SCANNED: Tables:25 | Rows:2179 | Cells:28029
    UPDATED: Tables:0 | Rows:0 | Cells:0
    ERRORS: 0
    RUNTIME: 0.157700 sec

    ====================================
    CONFIGURATION FILE UPDATES:
    ====================================

    UPDATED WP-CONFIG: /wp-config.php’ (if present)

    WEB SERVER CONFIGURATION FILE BASIC SETUP:
    – Preparing .htaccess file with basic setup.
    Basic .htaccess file edit complete. If using IIS web.config this process will need to be done manually.

    ====================================
    GENERAL UPDATES & CLEANUP:
    ====================================

    – Created directory wp-snapshots
    – Created file wp-snapshots/index.php

    ====================================
    NOTICES
    ====================================

    No Notices Found

    STEP 3 COMPLETE @ 12:51:34 – RUNTIME: 0.1616 sec.

    • This reply was modified 1 year, 10 months ago by  razvancs.
    • This reply was modified 1 year, 10 months ago by  razvancs.
    • This reply was modified 1 year, 10 months ago by  razvancs.
Viewing 8 replies - 16 through 23 (of 23 total)
  • The topic ‘'Invalid default value' = database install fail’ is closed to new replies.