WordPress.org

Support

Support » Plugins and Hacks » WP-Members: Membership Framework » [Resolved] Invalid argument supplied message

[Resolved] Invalid argument supplied message

  • I just upgraded from WPM 2.8.1 to 2.8.2. and have noticed that, when viewing the Admin > Users > All Users screen, if I then click on the ‘Screen Options’ tab, I see the following message:

    Warning: Invalid argument supplied for foreach() in /web1/user270/website/wp-content/plugins/wp-members/admin/users.php on line 643

    Any one any ideas, please?

    http://wordpress.org/extend/plugins/wp-members/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Chad Butler

    @cbutlerjr

    I’m wondering if there might be a collision with another plugin. Do any other plugins that you are using add columns to the user table?

    Hi Chad,

    Thanks for the prompt response. I do have other plug-ins which add columns – they are the Groups plug-in by itthinx and Email Users from Marvin Labs. I also have Role Scoper installed. However, I’ve tried de-activating both/all of those, but it hasn’t helped.

    However, I think this may be to do with the Groups plug-in, because I’ve just noticed that the column Groups provides is not populated by any data – whereas it used to be. If I deactivate WPM, the Groups column repopulates.

    Plugin Author Chad Butler

    @cbutlerjr

    That gives me something to go on. I have another user that indicated similar issues with BuddyPress.

    Do you know if you are you running WP in debug mode?

    Plugin Author Chad Butler

    @cbutlerjr

    I think I might have a fix (it should at least fix the empty groups column – hoping it fixes the other issue as well).

    The patch is explained and posted here.

    Wow! Worked like a charm – many thanks! (And, fixed both issues for me)

    Plugin Author Chad Butler

    @cbutlerjr

    Awesome! Thanks for getting back to me on that.

    That issue will be fully corrected in 2.8.3

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Invalid argument supplied message’ is closed to new replies.
Skip to toolbar