NextGEN Public Uploader
Invalid argument supplied foreach()... (4 posts)

  1. damiens
    Posted 3 years ago #

    Have tried this with 3.5 and now 3.4.2 - does anyone have this plugin working? I uploaded one image, now can't upload anything - getting the following error after the file upload appears to have completed;

    Warning: Invalid argument supplied for foreach() in /home/xxuserxx/public_html/wp-content/plugins/nextgen-public-uploader/inc/npu-upload.php on line 469


  2. Wade Stubanas
    Posted 3 years ago #

    I am having the exact same issue.

  3. Wade Stubanas
    Posted 3 years ago #

    damiens, got this figured out.

    In the public uploader setting, i specified the default gallery and thought I was goo to go.

    I checked my page where I had the uploader and it turns out I had specified in the shortcode a non-existant gallery (id=2).

    Once I changed it to 3 or deleted the whole ID part, it worked fine.

  4. Michael Beckwith
    Plugin Author

    Posted 2 years ago #

    A fallback and/or error message for these cases would not be a bad idea.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Public Uploader
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic