Support » Plugin: Product Feed PRO for WooCommerce » Invalid argument supplied for foreach()

  • Resolved lennilg

    (@lennilg)


    Errors before and after updating the plugin, never got it working.

    Debug.log https://drive.google.com/open?id=1F4r6PE5-kZ8C1RZKcyPkfItTkHOqxW1J

    Invalid argument supplied for foreach()

    wp-content/plugins/woo-product-feed-pro/classes/class-get-products.php:211
    do_action(‘toplevel_page_woo-product-feed-pro/woocommerce-sea’)
    wp-admin/admin.php:224
    woosea_generate_pages()
    wp-includes/class-wp-hook.php:286
    woosea_continue_batch()
    wp-content/plugins/woo-product-feed-pro/woocommerce-sea.php:2275
    WooSEA_Get_Products->woosea_get_products()
    wp-content/plugins/woo-product-feed-pro/woocommerce-sea.php:2634
    WooSEA_Get_Products->get_custom_attributes()
    wp-content/plugins/woo-product-feed-pro/classes/class-get-products.php:1688
    wp-content/plugins/woo-product-feed-pro/classes/class-get-products.php:211

    wp-content/plugins/woo-product-feed-pro/classes/class-get-products.php:1716
    do_action(‘toplevel_page_woo-product-feed-pro/woocommerce-sea’)
    wp-admin/admin.php:224
    woosea_generate_pages()
    wp-includes/class-wp-hook.php:286
    woosea_continue_batch()
    wp-content/plugins/woo-product-feed-pro/woocommerce-sea.php:2275
    WooSEA_Get_Products->woosea_get_products()
    wp-content/plugins/woo-product-feed-pro/woocommerce-sea.php:2634
    wp-content/plugins/woo-product-feed-pro/classes/class-get-products.php:1716

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor evavangelooven

    (@evavangelooven)

    Hi lennilg,

    Thanks for reaching out. Those seem as some pretty strange, and a lot, of errors.
    I assume you have WooCommerce enabled and it contains products too?

    Best
    Eva

    Thread Starter lennilg

    (@lennilg)

    Hi Eva. Yes I’ve got Woocommerce enabled and thousands of products. The error above has to do with Custom Attributes. I assume it’s a plugin conflict since it’s working fine on a fresh Woocommerce installation. Since I’ve got 44 plugins it’ll take some time to diagnose.

    Plugin Contributor evavangelooven

    (@evavangelooven)

    Hi lennilg,

    Ok, let me know the outcome of that so we can potentially help you solve the issue at hand.

    Best
    Eva

    Plugin Contributor evavangelooven

    (@evavangelooven)

    Assuming the issue at hand has been resolved and our support is no longer required I am going to close this topic for housekeeping reasons now.

    Please feel free to reach out whenever you need our help again.

    All the best
    Eva

    Thread Starter lennilg

    (@lennilg)

    Yes, and No. I had to find another plugin since I couldn’t get it working. But you may close the thread.

    Plugin Contributor evavangelooven

    (@evavangelooven)

    Hi lennilg,

    Sorry to hear that, we would have loved to solve the issue at hand.

    Anyhow, wishing you all the best
    Eva

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Invalid argument supplied for foreach()’ is closed to new replies.