Support » Plugin: Mailchimp for WooCommerce » Invalid Argument Supplied error

  • Resolved aaronrobb

    (@aaronrobb)


    Hi, we’ve noticed while debugging our site that we get this error:

    Warning: Invalid argument supplied for foreach() in /wp-content/plugins/mailchimp-for-woocommerce/bootstrap.php on line 306

    Not sure if this majorly affects the plugin, but just thought we should let you know here.

    That line in the code shows:
    foreach ($stores as $mc_store) {aand looks like it the file itself was updated maybe around September 26th of this year (or at least that’s when it was updated on our site).

    Any suggestions to fix this error?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author ryanhungate

    (@ryanhungate)

    @aaronrobb that’s interesting to hear – but sounds more like we may be in a situation where your server is being blacklisted by the API gateway Akamai.

    Can you please open up your plugin log to see if you’re seeing a bunch of errors? If so, please email them to ryan (at) vextras.com so I can diagnose them.

    Plugin Author ryanhungate

    (@ryanhungate)

    @aaronrobb considering it’s been a month since you’ve responded, we’ll mark this as closed. If you haven’t done so – please upgrade your plugin to the latest version 2.3. We even have another release coming out soon 2.3.1 which will be fixing a few other API connectivity issues as well so stay tuned for that as well.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.