Support » Plugin: Block Gallery - Photo Gallery Gutenberg Blocks » Invalid argument supplied

  • Resolved ndcadmin

    (@ndcadmin)


    Just another note about some errors popping up.
    PHP Warning: Invalid argument supplied for foreach() in /wp-content/plugins/block-gallery/class-block-gallery.php on line 165

    This is with the latest update to Version 1.1.3

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Rich Tabor

    (@richtabor)

    Hi @ndcadmin, what version of PHP are you using?

    Thread Starter ndcadmin

    (@ndcadmin)

    ahh… currently 5.4.16

    was planning on upgrading to 7.

    • This reply was modified 5 years, 2 months ago by ndcadmin.
    Plugin Author Rich Tabor

    (@richtabor)

    I switched to 5.4.16, but I wasn’t able to replicate the issue. Do you have a screenshot perhaps? Or at least, where are you seeing the warning?

    Thread Starter ndcadmin

    (@ndcadmin)

    Its spitting out in the php_errors.log

    Plugin Author Rich Tabor

    (@richtabor)

    Hey @ndcadmin,

    First off – thanks for being patient!

    I’m not sure why you’re getting an error on your end, but I am actually pulling that function out. I don’t really need it anyhow, now that Gutenberg is in core.

    I’ll have an update posted this evening with this, as well as a few other improvements:

    = 1.1.4, December 12, 2018 =
    * New: Add toggles for turning image captions on/off for each block
    * New: Add new "none" Caption Style option
    * New: Add new options for slider autoplay times up to 10 seconds [thanks @batracy]
    * Fix: Resolve translatable placeholder issue in the Slider Settings panel [thanks @morganestes]
    * Fix: Resolve translatable invalid HTML issue in the Carousel block [thanks @morganestes]
    * Fix: Resolve issue where the Carousel autoplay speed was not functioning properly [thanks @morganestes]
    Thread Starter ndcadmin

    (@ndcadmin)

    No worries! Thanks again for the hard work on this block.

    Will roll update 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Invalid argument supplied’ is closed to new replies.