WordPress.org

Support

Support » Plugins and Hacks » User Admin Simplifier » [Resolved] Invalid Argument in WP Admin Popup Windows

[Resolved] Invalid Argument in WP Admin Popup Windows

  • Hi Adam-

    I am getting the following error in any popup window in the WP Admin area:

    Warning: Invalid argument supplied for foreach() in /home/content/08/10944408/html/wp-content/plugins/user-admin-simplifier/useradminsimplifier.php on line 36

    The same error shows when in any type of popup window for any plugin. It does not appear in normal admin pages, and the plugin still seems to be functioning correctly, despite the error.

    Thanks,
    Rob

    http://wordpress.org/extend/plugins/user-admin-simplifier/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Adam Silverstein

    @adamsilverstein

    thanks for reporting the bug, i will try to fix. a few questions:

    how are you getting a popup – just the ‘add media’ button? what wp version are you running and what other plugins are enabled?

    Hi Adam-

    Thanks for the reply. While I thought this was happening in all popup windows, I’m not able to reproduce that. It only appears to show the error in popup windows generated by a theme. WP and plugin windows seem to be fine. i.e.: A theme-generated “shortcode” popup window in the WYSIWYG editor.

    I’m running WP 3.5.1 – the error occurs with “User Admin Simplifier” as the only active plugin.

    If you’d like to take a look, let me know, and I can provide an example for you.

    Thanks,
    Rob

    Plugin Author Adam Silverstein

    @adamsilverstein

    i would be happy to take a look. what theme are you using thats generating the popup? can you give me a test URL?

    Thanks Adam. Give me your email address and I will email you access info.

    Plugin Author Adam Silverstein

    @adamsilverstein

    adams dash email at earth bound dot com

    Plugin Author Adam Silverstein

    @adamsilverstein

    never got your email, maybe spam blocked? try the contact form on earthbound.com.

    Thanks for following up, Adam. I’ll try sending login info again when I’m back on Tuesday.

    Plugin Author Adam Silverstein

    @adamsilverstein

    ok, i corrected the issue with an explicit check for the $menu variable, if you download the latest version the issue should go away.

    thanks for helping me resolve that!

    Thanks so much Adam!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Invalid Argument in WP Admin Popup Windows’ is closed to new replies.
Skip to toolbar