Support » Plugins » Introducing the Smart Archives plugin for WordPress

Viewing 15 replies - 1 through 15 (of 18 total)
  • Great, thank you!

    Is there a simple hack to have it exclude certain categories? An Asides type category, for example.

    Justin, this plugin looks really cool. Good times.

    Now, can someone direct me to a page that shows me how I can get this script to display on like Justin has it set up? There’s got to be some documentation out there on how to do this, but all the search terms I’m using are so general that I get unrelated results.
    It stinks being a n00b. Thanks in advance!

    I created a page called “allarchives.php” that consisted of:
    <?php /*Template Name: All Archives */ ?>
    <?php get_header(); ?>

    <div id="content">
    <?php smartArchives() ?>

    <?php get_sidebar(); ?>
    <?php get_footer(); ?>`

    which I uploaded to my Content folder. Then I created a new blank Page (using the “Write Page” section of the Admin panel) called “All Archives” and set allarchives.php as the template.

    The result can be seen here.

    Does anyone know how to do this with the old format of index.php? I would love to get this working but am having problems getting a blank page template with 1.5 (had it working with 1.2) to call up with the code in it. I used Podz’ tutorial to make the original static page but it doesn’t seem to work in 1.5

    I’ve just released v1.01 of the Smart Archives plugin which takes care of most of the issues that users have written to me about. I encourage you to check out the changelog and upgrade.

    I followed Anthony’s instructions by creating an /archives.php page, but I don’t know what should I do in order to use it as a template for the “Archives” page (created with “Write page”).

    Any idea? Thanks!

    When you write your “Archives” Page – select the Page template named “All Archives” from the dropdown menu below the text area.

    I would like to do that :), but I can’t find any dropdown menu below the text area. Here’s all that’s there:

    Page Options
    Page slug:
    Page owner:
    Page Order:

    What am I missing?

    It might be your theme doesn’t have a Page template (page.php)

    It does have a page.php. Since the page template dropdown menu doesn’t show, I thought it might be a problem with:
    $page_template = 'default';
    in /wp-admin/page-new.php, but I can’t figure out if it’s something missing, or if I shoud change anything.

    Dumb question: did you upload the created template file into your active theme directory?

    I have installed Smart Archives here and it looks fine. Click on individual entries and it will take you to the full post, but I get a 404 error when I click on the months or the year:

    The requested URL /fotoblog/archives/2005/08/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Can anyone tell me what the problem is? Appreciate any help…


    As explained on the project page, you need to setup your permalink structure to follow /archives/year/month/day/post-name.

    Ok, I put this in the structure field in the permalinks tab under options:


    Now the archives don’t show at all. Could you be a little more specific? It also said this below it:

    If your .htaccess was writable we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    …And then there was a whole lot of code in another field at the bottom. Sorry, it’s been a while since I played with WP…

    Ok, worked it out. Just had to put that code into my .htaccess file. Was having problems locating it as my ftp program wouldn’t show any hidden files etc etc.

    Thanks for the little push.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Introducing the Smart Archives plugin for WordPress’ is closed to new replies.