Support » Plugin: WP-Invoice - Web Invoice and Billing » Intial setup saved – cannot make changes after

  • I setup WP-Invoice and I gave it all the default values I want.

    I tried to go back in and adjust the settings by adding a line item and even changing the default level in which someone can create an invoice, press save.. and it looks like everything is fine, but if I log out and back in, it all goes back to what it was before.

    https://wordpress.org/plugins/wp-invoice/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Anton Korotkoff

    (@anton-korotkoff)

    WP-Invoice Support

    Hey,

    do you get 404 or 406 or maybe 500 error after you click save settings?

    No errors at all.. its like it doesn’t even process the save request. everything else works fine on the site..

    what is the best way to remove it entirely and reinstall it?

    Dear Anton

    I am getting a similar problem, and I see an older post some 7 months back that raises similar issues with the Settings page failing to save.

    I get a 404 page not found error… here is the error logs I extracted from the Firebug’s NetPanel analysis of the POST request that is made when I click the Save All Settings button.

    Here are the reqest headers

    Here is a pdf of the POST request parameters

    I hope this can help

    Some back ground to the site: we initially installed the WP Invoice on a beta site, which we then deployed live and renamed the domains. All our other plugins works fine, only WP Invoice seems to have been left in a lurch. I uninstalled, deleted the plugin and reinstalled but no success.

    I managed to get the mod_security logs from my host…I am on shared hosting so had to raise a ticket for these.

    [Thu May 08 05:06:37.018178 2014] [:error] [pid 568274] [client 106.51.234.234] ModSecurity: Access denied with code 403 (phase 2). Match of “rx ://%{SERVER_NAME}/” against “ARGS:wpi_settings[billing][wpi_paypal][settings][test_mode][value]” required. [file “/usr/local/apache/conf/modsec_rules/10_asl_rules.conf”] [line “1243”] [id “340464”] [rev “56”] [msg “GreenGeeks.com WAF Rules: Remote File Injection attempt in ARGS (admin.php)”] [severity “CRITICAL”] [hostname “admin.syllogic.in”] [uri “/wp-admin/admin.php”] [unique_id “U2tXLK3sPNIACKvSqZIAAAAi”]
    [Thu May 08 05:11:15.172140 2014] [:error] [pid 624838] [client 106.51.234.234] ModSecurity: Access denied with code 403 (phase 2). Match of “rx ://%{SERVER_NAME}/” against “ARGS:wpi_settings[billing][wpi_paypal][settings][test_mode][value]” required. [file “/usr/local/apache/conf/modsec_rules/10_asl_rules.conf”] [line “1243”] [id “340464”] [rev “56”] [msg “GreenGeeks.com WAF Rules: Remote File Injection attempt in ARGS (admin.php)”] [severity “CRITICAL”] [hostname “admin.syllogic.in”] [uri “/wp-admin/admin.php”] [unique_id “U2tYQq3sPNIACYjGOuIAAABB”]
    [Thu May 08 05:14:27.100011 2014] [:error] [pid 632479] [client 106.51.234.234] ModSecurity: Access denied with code 403 (phase 2). Match of “rx ://%{SERVER_NAME}/” against “ARGS:wpi_settings[billing][wpi_paypal][settings][test_mode][value]” required. [file “/usr/local/apache/conf/modsec_rules/10_asl_rules.conf”] [line “1243”] [id “340464”] [rev “56”] [msg “GreenGeeks.com WAF Rules: Remote File Injection attempt in ARGS (admin.php)”] [severity “CRITICAL”] [hostname “admin.syllogic.in”] [uri “/wp-admin/admin.php”] [unique_id “U2tZAq3sPNIACaafJOAAAAAf”]

    Plugin Contributor Anton Korotkoff

    (@anton-korotkoff)

    WP-Invoice Support

    As you can see one of your mod_sec rules prevents from sending the value of ‘wpi_settings[billing][wpi_paypal][settings][test_mode][value]’ field which it supposes to match “rx ://%{SERVER_NAME}/” but it is not.

    That’s why plugin cannot save required date to work with. You need to contact your provider to ask them to help with the rule, or change the provider.

    From our side, we do not see any reason to prevent paypal site URL from saving to your database.

    Thanks.

    Hello Anton

    thank you for the feedback. We host our site on a shared hosting platform which doesn’t give us much leeway in terms of mod_security settings, so I guess we will have to find another solution.

    anyhow, thank you for your reply, much appreciated.

    kind regards

    Plugin Contributor Anton Korotkoff

    (@anton-korotkoff)

    WP-Invoice Support

    That’s ok. Let us know if you have any other product related questions.

    Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Intial setup saved – cannot make changes after’ is closed to new replies.