Support » Fixing WordPress » Internet Explorer messing up Formatting

Viewing 5 replies - 1 through 5 (of 5 total)
  • It’s cleaner if you put the align in your css file
    or you could also try
    <div style=’margin: auto; text-align: center;’>
    margin: auto centers your content,
    text-align: center also makes this work in IE

    Also google for embedd and object.
    W3C and IE have a different idea as to how you should embedd flash and youtube stuff in a page. Believe Alistapart also wrote some articles about it.

    hope this helped


    also might wanna install webdevelopper plugin for firefox from
    Once installed, under the ‘tools’ option choose validate html. You’ll notice that your page doesn’t validate due to a link tag that isn’t closed,…


    do this instead:

    <object class="movie" type="application/x-shockwave-flash" style="width:425px; height:350px;" data=""><param name="movie" value="" /><param name="wmode" value="transparent" /></object>

    then center the movie or whatever using CSS:

    .movie {
            margin-bottom: 10px;
    	padding: 4px;
    	border: 1px solid #ff0000;

    Note that Ive removed the embed tags — you dont need them. Using the code above will display youtube movies in all browsers that have the latest flash installed.

    W3C Validator revealed the mistake I had made.
    I had forgot to close a center tag.
    Thanks for the help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Internet Explorer messing up Formatting’ is closed to new replies.