Support » Fixing WordPress » Internet Explorer jumps to middle of the page

  • I just noticed that when visiting my site via IE (v 9.0.8) the visitorns jumps to the middle of the page and they are not able to see the top of the page (if a page is long). I did not have this problem for 2 weeks ago (last time i visited my blog with IE).

    Does anyone know whats causing this?

    i have done a few changes to the blog, but i removed the changes but its still happening.

    Take a look for yourself, Enter this page: http://funny-pictures-blog.com/2012/05/21/when-theres-no-internet/ using IE

    Heres a screenshot of how it looks like in my IE: http://i.imgur.com/Xkz3x.jpg

Viewing 12 replies - 1 through 12 (of 12 total)
  • Please note that this problem is ONLY in IE and not with Chrome or Firefox.

    Moderator kmessinger

    (@kmessinger)

    but i did have them before tho, even with those “errors”. Does IE jump to middle of the page when entering this URL? http://funny-pictures-blog.com/2012/05/21/when-theres-no-internet/

    possibly somehow related to the <div id="bannerleft" ....

    to see where that div hangs around, try to add a temporary background color to it.

    – no suggestion for a solution apart from removing the div, and/or reconsidering the formatting of that div.

    alchymyth –> i have now removed the entire code there, and reseted to what i had for 2 weeks ago, but IE is still jumping

    seems to be fixed – when I view the link in IE7, the site appears ‘normally’ at the top.

    – possibly clear the browser cache to see any changes (?)

    yeah already tried to clear the cache without any results. i think the problem only appears with IE9 tho, and not IE7

    Moderator kmessinger

    (@kmessinger)

    It is ok in 7 and 8.

    Moderator kmessinger

    (@kmessinger)

    When I try to check how many sites are on the server with you I get Invalid remote address. Is there some redirect going on?

    Goggle this, Internet Explorer jumps to middle of the page, and you will find it happens to a lot of people for different reasons.

    kmessinger –> the site is on a dedicated server. Its the only site on the server.

    could it somehow be a setting on my IE that does this? i use IE maybe 1 time / year. so i dont know how IE works

    Moderator kmessinger

    (@kmessinger)

    I don’t think so. I see it on my IE9.

    Have you tried:
    – deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder (rename it, open site) by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.
    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    yeah tried that before. its defiently something with my header.php or single.php that causing this. it worked for 2 weeks ago before i started to make some small changes, but i have changed them back to original now and it still wont work (and yes, the servers and my browsers cache was deleted)

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Internet Explorer jumps to middle of the page’ is closed to new replies.