WordPress.org

Support

Support » Themes and Templates » [Resolved] Internet Explorer and submenus

[Resolved] Internet Explorer and submenus

  • santiquel
    Member

    @santiquel

    Hi, I have installed the WordPress Theme Babylog in mermeladamermelada.com
    The theme is very nice and I like the look but I have a problem with the submenus. When I create subpages I see de submenus perfectly using using Firefox o Chrome but when I use Internet Explorer the submenus are transparent.

    Somebody knows how to change this?

    Thanks a lot for your atention.

    Regards.

    Santi.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Theme Author Caroline Moore
    Member

    @sixhours

    Hmm, the menus are working for me in IE 9+. My guess is you’re using an older version of IE that doesn’t support color transparency. You might be able to find a plugin to help with this, but in general, my themes are developed for modern browsers and won’t work perfectly for versions older than IE 9.

    You could also create a child theme or Custom CSS plugin (like Jetpack) and change the background colors such that they’re opaque.

    santiquel
    Member

    @santiquel

    Thanks Caroline for your quick answer.

    Yes, I use IE8 but the problem is than many people use that version. I will try to follow your instructions and try to change the color.

    But is curious de color in Firefox anf Chrome is rose.

    Ok, I will work in that.

    Thanks a lot.

    Santi.

    Theme Author Caroline Moore
    Member

    @sixhours

    You’ll see properties applied to the submenus that look like this (color numbers not exact):

    rgba(255,255,255,.5);

    The first three numbers are the red, green, and blue values for the color, the last number (.5) is alpha (transparency). The alpha property doesn’t work for IE browsers < IE 9, so you can fix it by simply removing the opacity and changing it to rgb:

    rgb(255,255,255);

    Replacing those color values with the ones in the theme. That should still work in older browsers while preserving the original color.

    santiquel
    Member

    @santiquel

    Hi Carolina, sorry but I have no time enough for try the solutions than you suggest until today.

    If I delete the transparency the theme don’t show the menus. I try many solutions but no one works.

    I have a idea….is better if the people update the browser to see the blog.

    Thank you very much for your attention and thanks a lot for let the people use your theme.

    Regards,

    Santi

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Internet Explorer and submenus’ is closed to new replies.