Support » Plugin: WooCommerce Shipping & Tax » International Flat Rate Shipping not working

  • Resolved TomBirmingham

    (@tombirmingham)


    I have set up international shipping for four countries. I have enabled flat rate shipping. I have assigned shipping classes to appropriate items. I have assigned shipping amounts to the classes in each country.

    However, the shipping rate defaults to the local shipping amount. I am not sure what I am doing incorrectly.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author frosso1 (a11n)

    (@frosso1)

    Hi there,

    I’m not seeing the “WooCommerce Shipping & Tax” extension installed on the site provided.

    However, it sounds like some help is needed with the “flat rate” shipping class configuration.
    This is an example of setup that seems to be working in my case:
    – This is how I have the “Flat Rate” shipping method setup for US destinations: https://d.pr/i/0zqyPn
    – This is how I have the “Flat Rate” shipping method setup for non-US destinations: https://d.pr/i/0zqyPn
    – This is how a product of “Class 2” is calculated for me at checkout for a US destination: https://d.pr/i/cmRO9u
    – This is how a product of “Class 2” is calculated for me at checkout for a non-US destination: https://d.pr/i/K5rjxW

    The shipping cost is calculated based on the amount entered on the specific class.

    In case this isn’t clear, here’s a link to the documentation on the “Flat Rate” shipping method: https://docs.woocommerce.com/document/flat-rate-shipping/#section-2

    If it’s still troublesome, you still have a few options:
    – Get assistance in a forum, such as WordPress.org – a lot of community members are there
    – reaching out to the WooCommerce public forum: https://wordpress.org/support/plugin/woocommerce/ (since the issue is with the “flat rate” shipping option, which is not covered by “WooCommerce Shipping & Tax”)
    – if you purchased a plugin on woocommerce.com, you can also create a ticket

    I hope this helps!

    In the meantime, stay healthy and stay safe!

    Francesco

    Thread Starter TomBirmingham

    (@tombirmingham)

    Thanks for your help, Francesco. I have looked at the pages you linked me to. with my review, it seems like I am doing it correctly, but obviously that isn’t the case.

    If you have a few minutes, here are links to screenshots of the pertinent pages on my wordpress site –

    Links to screen shots –

    Product with Shipping Class –
    https://drive.google.com/file/d/1aylZU7drDteezPH671FjLYRm6eReYQUC/view?usp=sharing

    Zone Page with selected countries –
    https://drive.google.com/file/d/1ZqtYa4HVU1dPvOSk2GcKSraHFvJtS50Q/view?usp=sharing

    Flat Rates for UK Zone –
    https://drive.google.com/file/d/1FRCkFG4m2J87_qFTNGucs9bAkX6KKDdv/view?usp=sharing

    If you can see what I am doing wrong, I will be eternally grateful.

    Plugin Author frosso1 (a11n)

    (@frosso1)

    Hi Tom,

    Thanks for the screenshots!
    Your setup looks good from what I can see! I went into your site and on checkout I am _not_ seeing the correct price: https://d.pr/i/aFf0n8

    I also tried to reproduce it on my site, but it seems to be working as expected in my case:
    – Product: https://d.pr/i/Het2ft
    – UK Shipping zone: https://d.pr/i/rtwZSy
    – UK Flat Rate settings: https://d.pr/i/2bqf53
    – Cart: https://d.pr/i/SgmdDS

    I would recommend a few next steps:
    – From your screenshots, it seems that the “UK” shipping zone is marked as “Everywhere”. Please make sure a region is selected: https://d.pr/i/aFf0n8
    – From your screenshots, it looks like there are a few updates that need to be performed on the WooCommerce database. Can you please ensure you’re using the latest version of WooCommerce and ensuring that the “WooCommerce database update required” notice does not appear? After the update is done, you can check the cart again to see if the problem has been resolved.
    – Another thing that is usually recommended in cases like these is to do a “conflict test”. In short, you can disable all the plugins (excluding WooCommerce and your payment gateway) and setting up the Storefront theme, to see if the issue is resolved. If it is, you can then enable one plugin at a time to help determine what is causing the issue.

    In your specific case, I’d be interested to see if the issue still persist after updating the region and updating the WooCommerce database/extension.

    Let me know if this helps!

    Thread Starter TomBirmingham

    (@tombirmingham)

    Thanks Francesco, I will try what you say, and let you know.

    Tom

    Thread Starter TomBirmingham

    (@tombirmingham)

    So…I figured out a problem I was having, and maybe have cured things (I won’t really know until the next international order)

    First – I had not added Australia as a country I sell to, so the zone title “Australia” and the region “everywhere” were just words they didn’t make anything happen.

    Once I added Australia as a “sell to” country, then, of course, the zone appeared in the drop down menu, and I was able to select it as a zone.

    I think, I really may not have been successfully using the US shipping zone either. When I removed “Everywhere” from that zone and selected “United States (US)” from the drop down it populated to the shipping zone page.

    I think my US shipping prices were coming from my “everywhere else” zone, and that may be why I wasn’t noticing the problem with the US.

    We’ll see how it goes, and thanks for the help.

    Plugin Support AW a11n

    (@slash1andy)

    Automattic Happiness Engineer

    Glad to hear that it should be sorted.

    Let us know if there’s anything else that comes up.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘International Flat Rate Shipping not working’ is closed to new replies.