Support » Fixing WordPress » International characters

  • recently i have updated my installation to the latest nightly build.
    The problem is that all the international characters like “á”, “é”, “í”, “ó”, “ú” and “ñ” now are “?”
    how can i correct it?
    thank!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Please give us your URL. Check the Encoding Option (should be utf-8), and the header of your index.php (or wp-header.php if you use it). The blog entries, the “hardcoded” text in index.php, the Encoding Option and the header must all have the same encoding. For you, iso-8859-15 would also be possible, even if utf-8 is better all around.

    the URL:
    http://www.lenguao.com
    Thanks!

    Your older posts seem to be in iso-8859-1 or -15 encoding. In this case the easiest thing would be to set the encoding option to iso-8859-15 (not -1; -15 has the € sign, which you might want to have). Then clean up the last few posts.
    You must have changed the encoding to utf-8 when you upgraded.
    (And for your next blog, start with utf-8 right away.)

    Tank you very much!!
    And Merry christmas!!!

    You’re welcome… and Feliz Navidad!

    Got the same problems as Lenguao, if I use ISO-8859-15, post previous to update are fine, but the new ones get strange looking. If I switch to UTF-8, new posts are allright, but all the previous post containing “á”, “é”, “í”, “ó”, “ú” and “ñ” turn into “?”
    What can I do?

    Not much…
    If you change the encoding sometime during your blogging then obviously your earlier posts get messy.
    I guess you should stick to your “original” encoding, i.e. use the same encoding even after upgrade. You can always change it in Options.

    To whom it may concern,

    I am new to blogging and to WordPress. I cannot figure out how to put in international characters (i.e. French accents) in my posts. Please advise.

    Many thanks,

    Jonathan Stern
    Latkekat@cs.com

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘International characters’ is closed to new replies.