Internal Server Error - While posting Code (4 posts)

  1. stuartc1
    Posted 10 years ago #

    Im having a big problem trying to post code to my blog.
    I've used it with rich text editor on and off - same problem.

    Im using the latest version and everything else works fine.

    For example if I try and post some javascript it give me a Internal Server error. But If I post just plain text it works fine.

    I've check my .htaccess file - but that is empty!!

    I've also tried to add print_r($_GET);die; at the top of post.php in the admin but that also gets the same error.

    Im running it on Fedora with Apache and using the latest version of wordpress (not an upgrade).

    Not sure what us happening here, any ideas???

  2. stuartc1
    Posted 10 years ago #

    BTW - if you search this site with 'server error' without the quotes - it give a XML error (try search, the when no results are found try the same search in the bigger search box)

    Im not having much luck - error after error ;(

  3. stuartc1
    Posted 10 years ago #

    Please - anyone? surely Im not the onlyone with this problem.

  4. stuartc1
    Posted 10 years ago #

    OK - It's obviously not a big problem to many people yet.

    If anyone is interested - reason for this problem is due to an apache module which is becoming more popular - called mod_security. This security feature prevents certain words from being accepted into the Server.

    To solve this, update the mod_security conf file - or add new rules to a folders .htaccess file (you can disable per directory).

    Search google for 'mambo mod_security' there is a good forum post on how to do this.

Topic Closed

This topic has been closed to new replies.

About this Topic