WordPress.org

Support

Support » Plugins and Hacks » Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) » [Resolved] Internal Server Error when switching to advanced editor

[Resolved] Internal Server Error when switching to advanced editor

  • Hey Robert,

    I’ve just installed the new version, and when I switch to the advanced editor to add a new marker, it comes up with this error:

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Any clues?

    Adventurous greetings,
    Coen

    http://wordpress.org/extend/plugins/leaflet-maps-marker/

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author RobertHarm

    @harmr

    Hi Coen,
    try switching to the advanced editor via Settings / Misc (& contact your server administrator for details – cant tell, what caused this)
    regards,
    Robert

    Okay, that saved my day. Got the advanced editor now. When I hit the switch to show the simplified editor, it troughs the same error at me?

    Plugin Author RobertHarm

    @harmr

    to bad – unfortunately I would need more info from server admin (which is you? 😉

    I also see this under the Maps Marker menu bar:

    $first_mlm_id: 7$other_mlm_ids: Array ( [0] => 8 [1] => 14 [2] => 25 [3] => 26 [4] => 31 )

    I don’t think it should be there.

    Adventurous greetings,
    Coen

    Plugin Author RobertHarm

    @harmr

    ups – thanks for reporting! missed that – output will be hidden in v3.1 (which I just wanted to commit and now has to wait a bit 😉

    good… anything else I will post here, I will be testing now… 😉

    Plugin Author RobertHarm

    @harmr

    Hi Coen,
    FYI: v3.2 will include a new function behind the editor switch link which should be more compatible…
    regards,
    Robert

    Great! Be happy to test it, if you have internet.. 😉

    Plugin Author RobertHarm

    @harmr

    🙂 testing is difficult unless you have a separate test environment (updating to the final release then could disrupt your system)

    Plugin Author RobertHarm

    @harmr

    Hi Coen,
    please test again with v3.2.1 – should work now.
    regards,
    Robert

    hmmm I get a nice big fat error in the latest update:

    Leaflet Maps Marker warning!
    You must enqueue the plugin stylesheets manually if you want to show maps by calling do_shortcode() in your template files!

    Please add the following code before your get_header() call inside your template, which is usually located in header.php:

    $plugin_version = get_option(‘leafletmapsmarker_version’);
    global $wp_styles;
    wp_enqueue_style( ‘leafletmapsmarker’, LEAFLET_PLUGIN_URL . ‘leaflet-dist/leaflet.css’, array(), $plugin_version );
    wp_enqueue_style( ‘leafletmapsmarker-ie-only’, LEAFLET_PLUGIN_URL . ‘leaflet-dist/leaflet.ie.css’, array(), $plugin_version );
    $wp_styles->add_data(‘leafletmapsmarker-ie-only’, ‘conditional’, ‘lt IE 9’);

    This is only for my maps in the sidebar.

    Plugin Author RobertHarm

    @harmr

    v3.2.2 will have a new option for this – no more template edits needed then…

    I think I must start doing offline testing for these things. Is there a way to downgrade to the last version, I haven’t downloaded that. And more over, can I just delete the new plugin and install a previous version?

    Adventurous greetings,
    Coen

    Plugin Author RobertHarm

    @harmr

    v3.2.2 will be released later today – no need to downgrade…

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Resolved] Internal Server Error when switching to advanced editor’ is closed to new replies.
Skip to toolbar