Support » Fixing WordPress » Internal Server Error upgrading WordPress on IIS7 server

Viewing 2 replies - 1 through 2 (of 2 total)
  • I am going to update my own post with my solution in the event there are other IIS7 users out there.

    What you have to do is to goto your IIS manager and then left click on the WordPress website. Then right click and click on Edit Permissions. Click on the Security tab and then click on the edit button.

    Then, click on IIS_USERS and click on the Modify permission. Click on OK. This will not only allow an automatic upgrade, it will also allow you to use your administrative pages to download and install everything that is offered.

    Mostly I am breaking my standards in that I NEVER, EVER allow any permissions other than read, but in this case I am truly hoping that the WordPress codebase is secure enough to prevent problems with these elevated permissions.

    I will be watching this like a hawk. What I may wind up doing is to just turn on the Modify permissions when I need them and then turn them off otherwise.

    Not sure if anyone has any thoughts on this. Anyone?

    thanks for coming back with this resolution
    it will be nice to be able to refer folks to this thread

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Internal Server Error upgrading WordPress on IIS7 server’ is closed to new replies.