Support » Localhost Installs » Internal Server Error on local Mac

  • I have wordpress as a local installation on my Mac at work.

    After finishing almost everything I have an eternal server error and don’t know why.

    The site is not online.

    I hope someone can help me asap.

    • This topic was modified 3 weeks, 3 days ago by Yui. Reason: moved to "localhost installs"
Viewing 15 replies - 16 through 30 (of 35 total)
  • Thread Starter jzenker88

    (@jzenker88)

    I tried to change the url of the main page to the correct one

    Thread Starter jzenker88

    (@jzenker88)

    The url was localhost:8888/wordpress
    and it should be localhost:8888/wordpress/index

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    “I tried to change the url of the main page to the correct one”

    And that’s when you broke it.

    You can’t just change the URL on an active WP site. What was it before? You’ll need to edit wp-config.php to put back the old value. See https://developer.wordpress.org/apis/wp-config-php/#advanced-options and reset the site URL.

    Thread Starter jzenker88

    (@jzenker88)

    Is this the paragraph you mean?

    Blog address (URL)
    
    Similar to WP_SITEURL, WP_HOME overrides the wp_options table value for home but does not change it in the database. home is the address you want people to type in their browser to reach your WordPress blog. It should include the http:// part and should not have a slash “/” at the end. Adding this in can reduce the number of database calls when loading your site.
    
    1
    define( 'WP_HOME', 'http://example.com/wordpress' );
    If you are using the technique described in Giving WordPress Its Own Directory then follow the example below. Remember, you will also be placing an index.php in your web-root directory if you use a setting like this.
    
    1
    define( 'WP_HOME', 'http://example.com' );
    Dynamically set WP_HOME based on $_SERVER[‘HTTP_HOST’]
    
    1
    define( 'WP_HOME', 'http://' . $_SERVER['HTTP_HOST'] . '/path/to/wordpress' );
    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    WP_SITEURL if what you changed whas the URL in settings->general.

    Thread Starter jzenker88

    (@jzenker88)

    Yes I changes the URL in the settings>general

    Thread Starter jzenker88

    (@jzenker88)

    And where do I put the code in the wp-config?

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    Please read the document. Put it anywhere before the comment that says “stop editing”.

    Thread Starter jzenker88

    (@jzenker88)

    Thanks man

    Thread Starter jzenker88

    (@jzenker88)

    Now I read the document and changed the code

    define( ‘WP_SITEURL’, ‘http://example.com/wordpress’ ) to the local address. but nothing happened after reloading the site.

    Thread Starter jzenker88

    (@jzenker88)

    I mean
    define( 'WP_SITEURL', 'http://example.com/wordpress' )

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    You can’t use “example.com” on localhost. Well, there may be a way to do that with MAMP, but I’ve never used it.

    Thread Starter jzenker88

    (@jzenker88)

    I changed the code to define( 'WP_SITEURL', 'localhost:8888/wordpress' )

    Thread Starter jzenker88

    (@jzenker88)

    Sorry for all that. I’ve really never worked with wordpress before. normally I write my html and css files by myself

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    Just for the record, I use https://localwp.com on my Mac.

Viewing 15 replies - 16 through 30 (of 35 total)
  • You must be logged in to reply to this topic.