Support » Fixing WordPress » Internal server error on comment

  • Resolved pathfinder

    (@pathfinder)


    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@oldpathfinder.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    I have searched for this error on comments and came up with some posts but all the solutions I tried don’t work.
    I am running 2.2.1 and when I try to post a comment I get this error.
    I have my WordPress installed in a subdirectory and I have the proper URLs in the option pages.
    I have comments allowed and I now have Akismet running and turned Pings and Trackbacks enabled.
    I have checked the permissions on wp-comment-post.php and they are set at 666 which seems correct.
    I am running out of patience. They did work at one time.

Viewing 2 replies - 1 through 2 (of 2 total)
  • whooami

    (@whooami)

    Member

    I have checked the permissions on wp-comment-post.php and they are set at 666 which seems correct.

    what on earth gave you the impression that was a “correct” permission?

    For the record, some hosts DO NOT allow world writable files, and consequently you’ll get an error like that.

    First, fix the permissions on your files:

    directories: 755
    files: 644

    then see if the error goes away — if it doesnt, check your server logs.

    That seems to have done it. Thanks. I was always unsure of the permissions. It seems to have been in the theme files.

    Nothing has ever shown up in the error log though.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Internal server error on comment’ is closed to new replies.