Support » Plugin: Duplicator - WordPress Migration Plugin » internal server error: malformed header from script ‘main.installer.php’

  • Resolved piepie2

    (@piepie2)


    Hi I am making a test migration for a website on a new shared host, but I can’t get past the first installer.php “automatic step”.
    From the server log I can see this error:
    malformed header from script ‘main.installer.php’: Bad header: Security Alert! The PHP

    If I download the file from FTP it looks correct, and the same package (installer+archive) works fine in my local WAMP.

    Same error occurs if I manually unpack the archive file: installer.php points to dup-installer/main.installer.php where I get the error.
    It succeeds unpacking dup-installer directory though.

    Any suggestion?

    Unfortunately I can’t edit much on the php.ini file of my new host, these are the values I may change:

    display_errors
    max_execution_time
    max_input_time
    memory_limit
    max_input_vars
    output_buffering
    post_max_size
    upload_max_filesize
    zlib.output_compression
    short_open_tag

    Thank you

Viewing 9 replies - 16 through 24 (of 24 total)
  • Until version 1.2.52 with 515 KB installer.php file the error does not appear.
    From Version 1.3.8 to Version 1.3.10 the error 500 always appears.

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @golfwordpress @maxgx

    Thanks for the feedback! If you can give the developer version a try it may have the updates for your issue. The very latest version (1.3.11) can be found by following these instructions:

    https://github.com/lifeinthegrid/duplicator/archive/master.zip
    – Uninstall your current version and install this one.

    If this doesn’t solve your issue, please submit a ticket (see link above) as we have not been about to reproduce the issues on any of our test servers.

    Thanks~

    Hi Cory,
    thanks for the reply.
    I found a simple solution (suggested by the hosting), the problem was the presence of the php.ini file in the dup-installer folder of the backup zip file, deleting this file and uploading installer.php and .zip everything works correctly.
    Thanks.

    For the new version I think it is sufficient to remove the creation of the php.ini file.

    • This reply was modified 3 months, 3 weeks ago by  golfwordpress.

    thanks @corylamleorg will try asap, as i should be transferring some developments pretty soon.

    @golfwordpress the “solution” your hosting gave you is exactly what @fabart and @roamingchile posted previously. in fact, you may end up having to remove (as i had to, similarly to @roamingchile) that php.ini file twice, first time when you run duplicator as usual, second time when you get anther 500 error and have to run it in manual mode.

    i quoted “solution” as it is by no means a real solution, as we all expect duplicator to run smoothly as it has always done – but i’m confident Cory’s already addressed it.

    @maxgx I agree that it is not a definitive solution and I hope that they will be resolved soon.
    I wrote the “new” procedure because it is faster to delete the php.ini file from the .zip file before uploading it, than to delete it twice while it is decompressing.
    Thanks.

    @corylamleorg just tested version 1.3.11 and it did work just fine.

    @golfwordpress apologies for my comment, i missed your “from the .zip” part 😉

    @maxgx it’s ok, no problem! 🙂

    Same problem here with the most popular Italian hosting Aruba.it, always used the plugin without any problems and now I was frustrated to encounter this problem, the only solution working seems to be deleting the php.ini file and extracting files manually before proceeding. Hope it will be solved in the near future.

    hey @adammadrzejewski try the beta version 1.3.11 @corylamleorg suggests above, it has worked fine for me.

Viewing 9 replies - 16 through 24 (of 24 total)
  • You must be logged in to reply to this topic.