Support » Plugin: Duplicator - WordPress Migration Plugin » internal server error: malformed header from script ‘main.installer.php’

  • Resolved piepie2

    (@piepie2)


    Hi I am making a test migration for a website on a new shared host, but I can’t get past the first installer.php “automatic step”.
    From the server log I can see this error:
    malformed header from script ‘main.installer.php’: Bad header: Security Alert! The PHP

    If I download the file from FTP it looks correct, and the same package (installer+archive) works fine in my local WAMP.

    Same error occurs if I manually unpack the archive file: installer.php points to dup-installer/main.installer.php where I get the error.
    It succeeds unpacking dup-installer directory though.

    Any suggestion?

    Unfortunately I can’t edit much on the php.ini file of my new host, these are the values I may change:

    display_errors
    max_execution_time
    max_input_time
    memory_limit
    max_input_vars
    output_buffering
    post_max_size
    upload_max_filesize
    zlib.output_compression
    short_open_tag

    Thank you

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @piepie2

    If you want to submit a support ticket for this issue we can have a closer look at your setup. Please provide a link to this thread when submitting the ticket.

    Thanks~

    Thank you Cory, no issues using a previous release of duplicator I had elsewhere (1.2.52).

    I’m still opening the ticket if this may help you fix it.
    🙂
    Thank you

    Plugin Author Cory Lamle

    (@corylamleorg)

    Thanks, we’ll try and do our best to see what is going on…

    Hi, I had the same problem, I’m no expert so I’ll just report what provider told me, hoping this is useful.

    I sent the error log to the provider support they told me the problem was the php.ini in the sub-folder dup-installer. They provided to renamed it as old_php.ini (I guess because they could not delete it) and then they told to procede with the wizard selecting the manual archive extraction.

    Hope it helps you.

    I’m using up to date version of duplicator.

    Thank you @fabart
    :))))))

    Plugin Author Cory Lamle

    (@corylamleorg)

    An update…

    If you can give the developer version a try it may have the updates for your issue. The very latest version (1.3.9) can be found by following these instructions:

    https://downloads.wordpress.org/plugin/duplicator.zip
    – Uninstall your current version and install this one.

    Let me know if this solves your issue~

    Thanks~

    • This reply was modified 6 months, 1 week ago by  Cory Lamle.

    thank you fabart
    @corylamleorg I just tried with the new release (1.3.9) : unfortunately I have the same error.
    If I rename the php.ini inside dup-installer subfolder it goes on, and gives the same error after archive extraction.

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @piepie2

    If you want to submit a support ticket for this issue we can have a closer look at your setup again if needed. Please provide a link to this thread when submitting the ticket.

    Thanks~

    roamingchile

    (@roamingchile)

    Thank you, @fabart! Renaming the php.ini fixed the Internal Server error I was getting.

    roamingchile

    (@roamingchile)

    In the end, I got another Internal Server error, because the php.ini inside dup-installer respawned. I deleted it again to be able to restart the installer and then restarted the process but using manual extraction (since the installer unpacked the archive before giving the error). That did the final trick. The site is finally migrated. Host: Dot5Hosting.

    Plugin Author Cory Lamle

    (@corylamleorg)

    Thanks for the udpate!

    having the very same problem with a package created with version 1.3.10 when trying to install it on a server i never had any problem with.

    i’m going to try @fabart and @roamingchile solutions and will update, but it definitely sounds strange that a plugin/setup which was previously working now creates such problem…

    yes, just renaming/removing /dup-installer/php.ini produces another 500, as @roamingchile pointed out: php.ini comes out again.

    retrying.

    ok, finally installed.

    the solution for me was the same @roamingchile pointed out:
    1) renaming/removing the file /dup-installer/php.ini
    2) set Options->General->Extraction: Manual

    thanks guys!

    please @corylamleorg could you let us know if/how all this can be avoided?
    thanks

    I’ve the same problem: coinciding with the new version 1.3.10 (before this version never had a problem), the error “500 internal server error” appeared after launching the installer.php, and the error log “malformed header from script ‘main.installer.php’: Bad header: Security Alert!”.
    Apart from the proposed solution, do you foresee a new version that solves the problem?
    Thanks.

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.