Support » Plugin: W3 Total Cache » Internal server error due to W3 Total Cache

  • When I wanted to access my site yesterday I got an internal server error. The same happened a few times today. I haven’t yet been able to find the problem, but the only major change I made to my site lately (besides approving comments and posting posts) was switching from Quick Cache to W3 Total Cache.
    I was now wondering if this could have caused an error somewhere?

    Thanks for your response.

Viewing 5 replies - 1 through 5 (of 5 total)
  • hmmm, very interrresssting.
    I’ve been having same issue for about a week now.
    Installed W3 Total Cache (because that’s what everyone recommends), right about the same time it was found to have a security flaw.
    So I deactivated and deleted it. Whoa wait a minute pardner, it’s not that easy. That thing spreads docs,files, code etc all over the site.
    Somewhere out there are directions to get every piece off your site, but damn it took a looooong time just to delete all the cache files it created.
    Now I’m wondering, maybe it’s not godaddy, maybe there’s still some trace of the W3 thing.
    Hopefully you have access to your ftp, you got a lotta sweepin’ to do if you want to get rid of it completely.

    Good Luck

    That’s worrying news about the W3 plugin.
    Could you tell me how to get rid of everything?

    Oh and it was GoDaddy. They’ve had server issues for more then a week. Said so themselves.

    GoDaddy issue, I tweeted ‘We should put on the front page, in big font, ‘This moment of page silence brought to you by GoDaddy’. Got response real quick. After several e-mails back and forth, which solved nothing, I finally deactivated (and deleted) some plugins, still white pages.

    It may be pure coincidence that they simultaneously fixed it right when I got all W3 stuff deleted, ya never know. All I know is the site is tremendously faster now. Then again, I did delete a lot of widgets too.

    In any event, there are several steps to getting rid of W3, moreso than just ‘uninstalling’.

    I used instructions from

    Here they are….

    To uninstall W3 total cache plugin, you need to follow following procedure:

    Delete W3 total Cache plugin from Wp-content/plugins folder

    Remove this line from Wp-config file (define(‘WP_CACHE’, true) )

    Delete advanced-cache.php, db.php, wp-total-cache-config.php and delete entire w3tc folder from wp-content folder.

    Check .htaccess file and if you see any code added by w3 total cache plugin, do remove it.

    Good Luck

    Thanks for that!
    Well I couldn’t put anything on my homepage cause I couldn’t even get onto that!
    I’ve still got the W3 plugin but it’s deactivated now and my site is working again, so I think it was purely GoDaddy

    Thanks for the help on how to uninstall W3 Total Cache FemmeFM

    Myself I have just generated 500s all over the place once activating the W3 Total Cache plugin. I’ll leave a separate post at the Help Forum, but am not sure, if there’s a fix to this. I saw various posts on internal server errors, which have not been resolved.

    Well, we’ll see. Cheers again for the helpful instructions in a moment of panic.

    Adding to the above: Before Installation you should be aware of the following (in quotes). Besides, that I’m not sure how to change that setting, could that be the reason for the Internal Server Errors? I doubt it though…

    Also make sure wp-content/ and wp-content/uploads/ (temporarily) have 777 permissions before proceeding, e.g. in the terminal: # chmod 777 /var/www/vhosts/ using your web hosting control panel or your FTP / SSH account.

    Thanks for any help and all the best!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Internal server error due to W3 Total Cache’ is closed to new replies.