Support » Plugin: WooCommerce » Internal Server Error after WP update 5.7.2.

  • Resolved giraffe75

    (@giraffe75)


    Hi folks,

    After yesterdays WP update 5.7.2. only the startpage of my website is loading/showing. When I click on ANY onpage link (e.g. login, information, catregories, …) I get this:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    
    Please contact the server administrator at webmaster@xxx.com to inform them of the time this error occurred, and the actions you performed just before this error.
    
    More information about this error may be available in the server error log.

    ERROR / Debug.log:

    [13-May-2021 06:54:59 UTC] PHP Notice:  Trying to access array offset on value of type bool in /www/htdocs/.../wp-content/plugins/woocommerce/includes/wc-template-functions.php on line 2568
    [13-May-2021 06:55:00 UTC] PHP Notice:  Trying to access array offset on value of type bool in /www/htdocs/.../wp-content/plugins/woocommerce/includes/wc-template-functions.php on line 2568
    [13-May-2021 06:55:00 UTC] PHP Notice:  Trying to access array offset on value of type bool in /www/htdocs/.../wp-content/plugins/woocommerce/includes/wc-template-functions.php on line 2568
    [13-May-2021 06:55:00 UTC] PHP Notice:  Trying to access array offset on value of type bool in /www/htdocs/.../wp-content/plugins/woocommerce/includes/wc-template-functions.php on line 2568

    And this is the part of my functions.php (line 2561-2570):

    function woocommerce_subcategory_thumbnail( $category ) {
    		$small_thumbnail_size = apply_filters( 'subcategory_archive_thumbnail_size', 'woocommerce_thumbnail' );
    		$dimensions           = wc_get_image_size( $small_thumbnail_size );
    		$thumbnail_id         = get_term_meta( $category->term_id, 'thumbnail_id', true );
    
    		if ( $thumbnail_id ) {
    			$image        = wp_get_attachment_image_src( $thumbnail_id, $small_thumbnail_size );
    			<strong>$image        = $image[0];</strong>
    			$image_srcset = function_exists( 'wp_get_attachment_image_srcset' ) ? wp_get_attachment_image_srcset( $thumbnail_id, $small_thumbnail_size ) : false;
    			$image_sizes  = function_exists( 'wp_get_attachment_image_sizes' ) ? wp_get_attachment_image_sizes( $thumbnail_id, $small_thumbnail_size ) : false;

    I noticed that it shows this debug note only after I loaded the startpage (where no error visibly occurs), but after clicking on any link and receiving the Error Message, there is no bug report in the debug file.

    Any ideas?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Mirko P. woo-hc

    (@rainfallnixfig)

    Hi @giraffe75,

    Thanks for sending the logs.

    Make sure to update WooCommerce to the latest available version as that may resolve the issue. If it doesn’t then provide us with a copy of your System Status so we can check into this further. You can find it via WooCommerce > Status. Select “Get system report” and then “Copy for support”. Once you’ve done that, paste it here in your response.

    Cheers!

    Thread Starter giraffe75

    (@giraffe75)

    Thank you Mirko,

    but I can’t do anything on the website, not even log in.

    So I can’t update anything, also can’t get that system report. Or is there another way by FTP or phpMyAdmin?

    Thread Starter giraffe75

    (@giraffe75)

    FALSE ALARM !

    I have to apologize, the error was caused by an inchoate entry in the .htaccess! as I was told by my server host.

    The timing of this error and WP update was only coincidental.

    Now I have to investigate, how or by whom (if not me) that file could have been altered. Prob. sound like my mom saying: “I haven’t touched anything, it just suddenly didn’t work anymore!”

    Thread Starter giraffe75

    (@giraffe75)

    solved.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Internal Server Error after WP update 5.7.2.’ is closed to new replies.