Support » Installing WordPress » Internal Server Error after upgrading to 3.1

  • Resolved izzetta


    Hi, I just tried to upgrade automatically my WP blog to 3.1 version, but it failed. I didn’t receive any message after clicking, the page remained white, just with header and left column. Now, for any action, it’s giving me the Internal Server Error message.

    The blog is at his address:, hosted by

    Can anybody help me? Thanks.

Viewing 15 replies - 1 through 15 (of 17 total)
  • I assume there is a problem with your htaccess, and its something like this:

    -you use certain plugin that writes php_value or php_flag to your htaccess
    -suPHP gives 500 ISE if there are php_value or php_flag

    Try putting default htaccess permalink code in your htaccess.

    If that doesn’t help, try removing whole htaccess, than try removing one plugin at the time to see which one causes problems.

    Sorry, I don’t get it. Can you mail me? ibubanj [at] Hvala.

    Also, check file and folder permissions, to be precise, folders must have 755 tops, and php files 644.

    Although, WP upgrade doesn’t change file permissions, but you can check anyway…

    One more thing, create a php.ini file in your website root and add following code:

    memory_limit = 20M

    Might help…

    Internal server errors (error 500) are often caused by plugin or theme function conflicts, so if you have access to your admin panel, try deactivating all plugins. If you don’t have access to your admin panel, try manually resetting your plugins, using ftp rename plugins folder to plugins_hold and create a blank plugins folder If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching Twenty Ten theme (WordPress 3.0 and higher) to rule-out a theme-specific issue. If you don’t have access to your admin panel, access your server via FTP or SFTP, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the Default theme Twenty Ten theme (WordPress 3.0 and higher) to activate and hopefully rule-out a theme-specific issue.

    If that does not resolve the issue, it’s possible that a .htaccess rule could be the source of the problem. To check for this, access your server via FTP or SFTP and rename the .htaccess file. If you can’t find a .htaccess file, make sure that you have set your FTP or SFTP client to view invisible files.

    If you weren’t able to resolve the issue by either resetting your plugins and theme or renaming your .htaccess file, we may be able to help, but we’ll need a more detailed error message. Internal server errors are usually described in more detail in the server error log. If you have access to your server error log, generate the error again, note the date and time, then immediately check your server error log for any errors that occurred during that time period. If you don’t have access to your server error log, ask your hosting provider to look for you.


    I agree with some points above, you should check:
    1. Files permissions and ownership
    2. .htaccess file of your blog.
    3. May be there’re is a need to reupload default wordpress files.
    4. Contact hosting support if all the above is ok, so they could check for server errors.

    Hi guys,

    I tried both with .htaccess and php.ini file but nothing happened. Then tried with this: ttp:// and it’t worked! The problem was with permissions.

    Thank you all for help.

    I’m having a similar problem. Ever since I upgraded to 3.0 I have to shut down all my plugins (including Akismet) in order to add or update posts or pages. The other day it stopped letting me add pages. So today I upgraded to 3.1 … I thought it couldn’t get worse. I was wrong. Now I can’t add posts either!

    I can get into the dashboard and the plugin page, but when I go to the posts or pages page, I get the following error page:

    Error 500 – Internal server error

    An internal server error has occured!
    Please try again later.




    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    – increasing the memory available to PHP:

    For me, the key was the .htaccess file. Once I temporarily renamed it, I could see the site again and verify the update.

    So far I’ve tried these things:

    * Deactivated all the plugins. This used to work. Now that I’ve upgraded to 3.1, it no longer does.

    * I’ve had a WP developer take a look at it. He says there are no problems with the plugins or the theme. I have tried switching out the theme and that didn’t work.

    * I’ve checked the permissions on every file and folder.

    * I upgraded from a fresh download of WordPress

    * I increased the memory from 64 to 128 in the wp-config file.

    * I deleted my .htaccess file.

    Still nothing. I’m going to call my hosting company,, and see if there’s a way to increase memory in there somehow. But this is really frustrating.

    You should check with your hosting company, maybe 500 ISE is not your fault.

    And check the permissions again, it seems to me that something MUST be wrong with them.

    I was having the same problem – but for me it was ONLY the .htaccess file with only 644 permission. Once I made it chmod 666, it worked like a charm.

    I know this is resolved, but maybe it helps others who – as I – came here to search for a solution.

    I called my hosting company ( and they say that php memory is capped at 30M. I’ve checked all the permissions and they are correct. I just want to cry … I have a weekly podcast and can’t post it because I can’t add pages or posts. I can only check comments and delete spam. This is so frustrating. I wish I never updated to 3.x!

    After upgrading to 3.1.1, I’m having also having issues with plugins. Mine seem to be a bit different than others though. I’m currently using Askimet, WP-Syntax, and Platinum SEO Pack. All are the current versions.

    I can have up to two plugins activated; it doesn’t matter which two. If I activate the third, I get a 500 error and either the plugin won’t actually activate or if I activate Askimet last, I have to manually reset my plugins.

    I have memory_limit set to 40M for something else (don’t remember what though).

    Any thoughts?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Internal Server Error after upgrading to 3.1’ is closed to new replies.