Support » Fixing WordPress » Internal Server Error 500,503

  • Resolved buyacsgo

    (@buyacsgo)


    when I’m checking my site is up or down from this URL:- https://www.uptrends.com/tools/uptime
    that time my site went down by showing this error:-

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at webmaster@buyacsgo.com to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Clayton James

    (@claytonjames)

    Internal server errors (error 500) are often caused by plugin or theme function conflicts, so if you have access to your admin panel, try deactivating all plugins. If you don’t have access to your admin panel, try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the default theme for your version of WordPress to rule-out a theme-specific issue. If you don’t have access to your admin panel, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue.

    If that does not resolve the issue, it’s possible that a .htaccess rule could be the source of the problem. To check for this, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, and rename the .htaccess file. If you can’t find a .htaccess file, make sure that you have set your SFTP or FTP client to view invisible files.

    If you weren’t able to resolve the issue by either resetting your plugins and theme or renaming your .htaccess file, we may be able to help, but we’ll need a more detailed error message. Internal server errors are usually described in more detail in the server error log. If you have access to your server error log, generate the error again, note the date and time, then immediately check your server error log for any errors that occurred during that time period. If you don’t have access to your server error log, ask your hosting provider to look for you.

    503 errors is basically a “Service Unavailable” response.

    [edit] – your site is currently not down, by the way. Some more reference material for you – 503 error explained – (Link goes to Google)

    buyacsgo

    (@buyacsgo)

    Hello Thanks for the reply. I had run my website with default .htaccess file and also tried with disable all unwanted plugins but problem not solved. That was a another issue with resources. That uptime checker website sends 190 bots at a time, that’s why my site went down because I have starter hosting plan which I bought from godaddy.

    Today I have added some scripts, after adding scripts I can see my site only went down when I’m using www.

    I have tested by using:
    buyacsgo.com
    http:/buyacsgo.com
    https://buyacsgo.com

    my site went down when I used http://www.buyacsgo.com ( I mean when I used www. )

    any solution ?

    Scripts I added:-
    # BLOCK PROXY VISITS | htaccess

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:VIA} !^$ [OR]
    RewriteCond %{HTTP:FORWARDED} !^$ [OR]
    RewriteCond %{HTTP:USERAGENT_VIA} !^$ [OR]
    RewriteCond %{HTTP:X_FORWARDED_FOR} !^$ [OR]
    RewriteCond %{HTTP:PROXY_CONNECTION} !^$ [OR]
    RewriteCond %{HTTP:XPROXY_CONNECTION} !^$ [OR]
    RewriteCond %{HTTP:HTTP_PC_REMOTE_ADDR} !^$ [OR]
    RewriteCond %{HTTP:HTTP_CLIENT_IP} !^$
    RewriteRule .* – [F]
    </IfModule>

    # 5G:[QUERY STRINGS]
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{QUERY_STRING} (environ|localhost|mosconfig|scanner) [NC,OR]
    RewriteCond %{QUERY_STRING} (menu|mod|path|tag)\=\.?/? [NC,OR]
    RewriteCond %{QUERY_STRING} boot\.ini [NC,OR]
    RewriteCond %{QUERY_STRING} echo.*kae [NC,OR]
    RewriteCond %{QUERY_STRING} etc/passwd [NC,OR]
    RewriteCond %{QUERY_STRING} \=\\%27$ [NC,OR]
    RewriteCond %{QUERY_STRING} \=\\\’$ [NC,OR]
    RewriteCond %{QUERY_STRING} \.\./ [NC,OR]
    RewriteCond %{QUERY_STRING} \: [NC,OR]
    RewriteCond %{QUERY_STRING} \[ [NC,OR]
    RewriteCond %{QUERY_STRING} \] [NC]
    RewriteRule .* – [F]
    </IfModule>

    # 5G:[USER AGENTS]
    <IfModule mod_setenvif.c>
    SetEnvIfNoCase User-Agent ^$ keep_out
    SetEnvIfNoCase User-Agent (casper|cmsworldmap|diavol|dotbot) keep_out
    SetEnvIfNoCase User-Agent (flicky|ia_archiver|jakarta|kmccrew) keep_out
    SetEnvIfNoCase User-Agent (libwww|planetwork|pycurl|skygrid) keep_out
    <Limit GET POST PUT>
    Order Allow,Deny
    Allow from all
    Deny from env=keep_out
    </Limit>
    </IfModule>

    # 5G:[REQUEST STRINGS]
    <IfModule mod_alias.c>
    RedirectMatch 403 (https?|ftp|php)\://
    RedirectMatch 403 /(cgi|https?|ima|ucp)/
    RedirectMatch 403 (\=\\\’|\=\\%27|/\\\’/?|\)\.css\()$
    RedirectMatch 403 (\,|//|\)\+|/\,/|\{0\}|\(/\(|\.\.\.|\+\+\+|\|)
    RedirectMatch 403 \.(cgi|asp|aspx|cfg|dll|exe|jsp|mdb|sql|ini|rar)$
    RedirectMatch 403 /(contac|fpw|install|pingserver|register)\.php
    RedirectMatch 403 (base64|crossdomain|localhost|wwwroot)
    RedirectMatch 403 (eval\(|\_vti\_|\(null\)|echo.*kae)
    RedirectMatch 403 \.well\-known/host\-meta
    RedirectMatch 403 /function\.array\-rand
    RedirectMatch 403 \)\;\$\(this\)\.html\(
    RedirectMatch 403 proc/self/environ
    RedirectMatch 403 msnbot\.htm\)\.\_
    RedirectMatch 403 /ref\.outcontrol
    RedirectMatch 403 com\_cropimage
    RedirectMatch 403 indonesia\.htm
    RedirectMatch 403 \{\$itemURL\}
    RedirectMatch 403 function\(\)
    RedirectMatch 403 labels\.rdf
    </IfModule>

    Clayton James

    (@claytonjames)

    my site went down because I have starter hosting plan which I bought from godaddy…
    …Today I have added some scripts, after adding scripts I can see my site only went down when I’m using www…
    …any solution ?

    Contact GoDaddy support and get their opinion on why using “www” makes any difference. Also have an honest conversation with them regarding your expectations and needs, and whether or not the plan you purchased is actually going to support your resource requirements. If you’re exhausting your resources and bring the site down that easily, you may simply need to consider a different plan option.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Internal Server Error 500,503’ is closed to new replies.