Support » Plugin: qTranslate X » Internal server error 500 after 3.4.6 update

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author John Clause

    (@johnclause)

    Could you please, look in the error_log and follow the initial troubleshooting in general: https://qtranslatexteam.wordpress.com/troubleshooting/ Last time I deal with 500 error, it was induced by malformed .htaccess file.

    Had the same error, error logs showed it was a redirect loop: “Request exceeded the limit of 10 internal redirects due to probable configuration error.”

    Resetting the settings of the plugin worked for me, afterwards you just need to enable your languages again to make sure everything is working.

    I had the same issue with a 500 error.

    My old .htaccess file was:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /es/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /es/index.php [L]
    </IfModule>

    # END WordPress

    (I had English and Spanish enabled)

    I deleted my .htaccess file and added a new one with this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Now it works fine. But I am wondering if I am missing something …..

    I had the same problem and the technical staff of my provider told me exactly to check in this .htaccees file if the line code

    RewriteBase /

    and

    RewriteRule . /index.php [L]

    have to be always written in this way…maybe can help understand it to someone. I just made acopy of the file and next time I will check it incase of.

    I did check the .htaccess file. There were no anomalies in the file. I did not find a solution to the problem so I was forced to restore a backup of my website. Still running 3.4.3 stable now.

    Plugin Author Gunu

    (@grafcom)

    @nelis1989
    as John asked:

    please, look in the error_log and follow the initial troubleshooting in general: https://qtranslatexteam.wordpress.com/troubleshooting/

    Plugin Author John Clause

    (@johnclause)

    @minilobo: This line would cause infinite redirect:

    RewriteRule . /es/index.php

    I am curious, where this extra ‘/es’ came from? Any idea?

    @nelis1989: I guess, you would have to make a test copy to investigate it without interrupting the main site. We will not be able to help, unless we can reproduce it.

    I think the original issue is resolved and we may close this ticket.

    If @nelis1989 needs more help, please contact us privately or open an issue at GitHub, when you find out something new during your troubleshooting. Thank you.

    Hello I have the same error ….

    I can not solve the problem, is it possible to recover the previous version of the tool? I can not tell my client to wait :(; (and I do not find the same solution by following your advice …
     
    Thanks for your help !

    @johnclause I was hoping for you to tell me ! 🙂

    I was in my .htaccess. At first I thought it had to be there, because I am using English and Spanish on the site and all the Spanish URLs start with domain.com/es/

    It all crashed while I was updating some settings of the theme (flatsome), but it could be a coincidence.

    Plugin Author Gunu

    (@grafcom)

    @davidhenaff

    can you copy the content of your .htaccess file here?

    Same error when swithing languages

    http://tehserviss.coma.lv/
    http://tehserviss.coma.lv/lv/

    Plugin Author Gunu

    (@grafcom)

    @vadikcoma

    can you copy the content of your .htaccess file here?

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /ru/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /ru/index.php [L]
    </IfModule>

    # END WordPress

    Plugin Author Gunu

    (@grafcom)

    RewriteBase /ru/

    should be RewriteBase /

    and

    RewriteRule . /ru/index.php [L]

    should be RewriteRule . /index.php [L]

    Thank you!

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Internal server error 500 after 3.4.6 update’ is closed to new replies.