Support » Plugin: WP Job Manager » internal server error 500

  • Resolved Yunis777

    (@yunis777)


    Hi,

    My website shows an ‘internal server error 500’ page after a user tries has created a Resume, presses a link received in her/his email, makes a password and tries to login. Do you know what is going on and how this cvan be resolved?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Yunis777

    (@yunis777)

    The WP Job Manager plugin goes awry after a user tries to log into the website with his/her email username and password. See this screenshot: https://s26.postimg.org/kteo3b789/500_internal_server_error.png

    My webhost has told me that it is because the plugin is ‘using a very large cookies’ and that generating shorter cookies would resolve the issue.

    After a user fills in the page https://beanjobs.com/register-your-skills/, confirms his/her email address and then tries to log into his account using their email address & password, they get an ‘500 – Internal Server Error’.
    See this screenshot: https://s26.postimg.org/kteo3b789/500_internal_server_error.png

    When the browsing data is cleared in it is visible again but I do not want user having to do that and see that page.

    My webhost has told me to see you because your WP Job plugin doing a very large cookie request. This is what webhost technical support has said the following to me:

    “The original request that results in error 500 is, it can be taken from a browser >> developer tools >> Network >> right click on the 500 error request >> Copy as curl:

    Code:
    curl ‘https://beanjobs.com/login/’ -H ‘pragma: no-cache’ -H ‘accept-encoding: gzip, deflate, sdch’ -H ‘accept-language: bg-BG,bg;q=0.8’ -H ‘upgrade-insecure-requests: 1’ -H ‘user-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.87 Safari/537.36’ -H ‘accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8’ -H ‘cache-control: no-cache’ -H ‘authority: beanjobs.com’ -H ‘cookie: wordpress_logged_in_e5daacf8d0b15a0298e71e5299b42894=paveldosev%7C1506775622%7CLj2MOLagUNpRcrWcgpeXmVo9dbv5sRHU22NKDUoZGDB%7Cfb9425fa3cb96586dc0345d24522f1f64cff6ded999ba3450fd0c53a665a73f1; _ga=GA1.2.1880442822.1505565964; _gid=GA1.2.529783117.1505565964; wfwaf-authcookie-fdc6735b21a24db3ee5e119ffaf73d95=70%7C%7C7bbbe84e61d02794b6dd759fdc5964cab4ce42fe37216efc3530af29866ec50d; wordpress_test_cookie=WP+Cookie+check’ -H ‘referer: https://beanjobs.com/login/?action=resetpass‘ –compressed

    If I get the same request but reducing the lenght of the cookie string the error is no longer showing:

    Code:
    curl ‘https://beanjobs.com/login/’ -H ‘pragma: no-cache’ -H ‘accept-encoding: gzip, deflate, sdch’ -H ‘accept-language: bg-BG,bg;q=0.8’ -H ‘upgrade-insecure-requests: 1’ -H ‘user-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.87 Safari/537.36’ -H ‘accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8’ -H ‘cache-control: no-cache’ -H ‘authority: beanjobs.com’ -H ‘cookie: wordpress_logged_in_e5daacf8d0b15a0298e71e5299b42894=paveldosev%7C150cb96586dc0345d245220fd0c53a665a73f1; _ga=GA1.2.1880442822.1505565964; _gid=GA1.2.529783117.1505565964; wfwaf-authcookie-fdc6735b21a24db3ee5e119ffaf73d95=70%7C%7C7bbbe84e61d0af29866ec50d; wordpress_test_cookie=WP+Cookie+check’ -H ‘referer: https://beanjobs.com/login/?action=resetpass‘ –compressed

    I suggest contacting its developer and asking him if it is possible to generate shorter cookies as this should resolve the issue

    Plugin Author jonryan

    (@jonryan)

    Hi @yunis777 I haven’t seen an issue like this before. Can you tell me what kind of hosting plan you are on. In theory a cookie size should not take down your site like this, so I’m wondering what your php.ini settings are like.

    jonryan,

    Thanks for your reply, although it is a bit late considering I sent the issue 2 weeks ago. The culprit has been traced to something else. It turns out that the plugin that is causing this cookie generation problem is ‘Limit Login Attempts’ which was last updated 5 years ago. See: the https://en-gb.wordpress.org/plugins/limit-login-attempts/.

    Regards,

    Yunis

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.