Support » Plugin: WP Social Bookmarking Light » Internal Server Error

  • Resolved stevie2012

    (@stevie2012)


    After updating to 2.0.0 from 1.9.2, an Internal Server Error happens.

    This was in the error log.

    “PHP Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /var/www/html/news/wp-content/plugins/wp-social-bookmarking-light/wp-social-bookmarking-light.php on line 44”

    Same thing has happened when I had updated “Hide Update Reminder” to 1.3.0 from 1.2.1. The culprit was that the author modernized its code. Right now, the author has fixed it and no error happens.

    Anyways, the server info that made this error are as follows:

    Server Info:
    WordPress
    Version 4.8
    Language ja
    Charset UTF-8
    Memory Limit 40M (Max 256M)

    PHP
    Version 5.3.3
    SAPI apache2handler
    User apache
    Process apache
    Safe Mode Off
    Memory Limit 256M
    Memory In Use 57.00 MB
    Max Execution Time 30
    Shell Exec Is Supported
    Shell Exec Zip Is Supported
    Suhosin Extension Disabled

    MySQL
    Version 5.0.45
    Comments Source distribution
    Charset utf8
    Wait Timeout 28800
    Max Allowed Packets 1048576
    msyqldump Path /usr/bin/mysqldump

    I hope that you’ll be able to fix this for people like us with old php and mysql servers which we cannot update on our own.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author utahta

    (@utahvich)

    Hi.
    If your WordPress site working on PHP 5.5 or lower, please continue to use v1.9.2 version.

    I didn’t intend to actively support on PHP 5.5 or lower, but i’ll think about it.

    Ok, Thanks for your reply. I’ll continue to use the old version then.

    Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/users/2/main.jp-460556a5f7b68453/web/wp-content/plugins/wp-social-bookmarking-light/wp-social-bookmarking-light.php on line 44

    が起きてます。

    ログインできず修正できません。どうしたらいいんでしょうか?

    @love-aus-is

    FTPなどでログインし、
    以下のところにある”wp-social-bookmarking-light”のフォルダーを削除しましょう。
    Login via FTP and delete the following “wp-social-bookmarking-light” folder.
    “/home/users/2/main.jp-460556a5f7b68453/web/wp-content/plugins/wp-social-bookmarking-light/”

    今のところそれ以外の対処はないですよ。Right now that’s the only way.
    もしくは前のバージョンに戻してアップデートをしないようにした方が良いと思います。
    Or, you can revert back to the previous version.

    契約したサーバーはどこ?What hosting are you using?
    PHPとMySQLのバージョンは?PHP and MySQL versions?

    作者が言うようにPHP5.3以下では最新のはサポートしないみたいですので、使用しているレンタルサーバーのPHPなどのバージョンアップをサーバー会社に行ってやってもらう必要があると思います。
    As the plugin author is saying, it won’t support PHP 5.3 or lower anymore, so you might want to get the hosting company to upgrade your program versions etc.

    • This reply was modified 2 years, 2 months ago by  stevie2012.

    PHPは見たところ5.3.29を使っているみたいですね。
    It looks like as you’re using PHP5.3.29。

    で、レンタルサーバー会社はlolipop。でしたら以下からPHPのバージョンを上げて見ては如何?
    And looks like you’re using lolipop as your hosting. Try updating your PHP version from below link.
    https://lolipop.jp/manual/user/php-setting/

    どうも、はじめまして、今回の問題が解決しました。ありがとうございます。

    当方はなんとかワードプレスのブログを作るというだけのモチベーションでなんとか作った程度の人間です。

    相対パスとかを全く意識なんてしない、ましてデベロッパーでもプログラマーでもないのでこういたことに関してはかなりの同様をしてしまいます。

    ありがとうございます!

    thanks to replay and gave me the current answer!

    I got calm and renew my weblog.

    I am recognized what important that have to check version and confirm whether happen the bag in my blog!

    this time , I could learn big things .

    I care this case every time after words….

    anyway , big thanks !!

    Plugin Author utahta

    (@utahvich)

    サイト全体に影響を与えてしまって本当に申し訳ないです。ひとまず解決されたようでなによりです。
    We sincerely apologize for any inconvenience.

    取り急ぎ 2.0.1 で PHP 5.3 上で動くように修正しました。
    We fixed this problem in 2.0.1 version.

    @stevie2012

    ありがとうございます!
    Thank you for your help!

    As for the current latest version of 2.0.1, its working on the server without problems as far as installation goes.

    Thank you for the fix!

    • This reply was modified 2 years, 2 months ago by  stevie2012.
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Internal Server Error’ is closed to new replies.