WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Internal Server error

[Resolved] Internal Server error

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Sean Voss
    Member

    @seanvoss

    Hey Anshul,

    Over the last 12 hours I’d tried something to work to fix a problem in some user’s systems, I failed, and more people had issues, so I reverted back to the stable setup i had previously.

    Try updating to 0.20 should be good.

    Thanks,

    Sean

    Plugin Author Sean Voss
    Member

    @seanvoss

    Haven’t heard back, so assuming all is well and marking resolved.

    I’m extremely sorry for THIS late reply, the plugin is working absolutely fine now. thank you Sean! Cheerio

    digitalbar
    Member

    @digitalbar

    Hello Sean,

    Testing out your plugin on woocommerce with Bazar theme.

    Seem to be having the same problem as the person above.

    Downloaded and installed .23 and now can not log into site. What comes up is:

    Parse error: syntax error, unexpected ‘:’ in public_html/wp-content/plugins/striper/stripe_gateway.php on line 31

    So I pulled line 31:

    $this->icon = $this->settings[‘alternate_imageurl’] ?: WP_PLUGIN_URL . “/” . plugin_basename( dirname(__FILE__)) . ‘/images/credits.png’;

    I can not see the problem

    Thanks for the help.

    digitalbar
    Member

    @digitalbar

    So is this the problem:

    “/”

    thanks again

    tony

    Plugin Author Sean Voss
    Member

    @seanvoss

    Hey tony,

    Looks like I used a shorthand that only works on newer versions of PHP

    I’ll make a patch to work for easier versions of PHP

    digitalbar
    Member

    @digitalbar

    tested the php as a whole and came up clean

    what am i missing

    thanks

    tony

    Plugin Author Sean Voss
    Member

    @seanvoss

    Hey,

    It’s the ternary operator, replace it on your version with everything to the right of ?:

    digitalbar
    Member

    @digitalbar

    Found it Sean

    took out the update of ‘imageurl’

    basically took line 31 of version 20
    and replaced it in line 31 in version 23

    from this:

    $this->icon = $this->settings[‘alternate_imageurl’] ?: WP_PLUGIN_URL . “/” . plugin_basename( dirname(__FILE__)) . ‘/images/credits.png’;

    to this:

    $this->icon = WP_PLUGIN_URL . “/” . plugin_basename( dirname(__FILE__)) . ‘/images/credits.png’;

    working now

    Thanks for getting back to me.

    If this works for me I will be donating on your blog.

    I will also be checking out your shipper plugin

    Thanks Tony

    Plugin Author Sean Voss
    Member

    @seanvoss

    Hey digitalbar,

    I uploaded 0.24 which should work for PHP 5.2 and lower, which was what I had you manually fix last night, so if you have a second, see if you can update and have it work.

    Cheers,

    Sean

    digitalbar
    Member

    @digitalbar

    OK…will give it a try. Integrating SSL and just received WP 3.8 update. Will try the updates in the next day.

    I am runiing: PHP version 5.3.27 Apache version 2.2.24

    just to let you know.

    Salute

    Tony

    digitalbar
    Member

    @digitalbar

    My stupidy

    version in WP is php 5.2.17

    host is the other

    Plugin Author Sean Voss
    Member

    @seanvoss

    Awesome, so that’s in line with what I was thinking.

    So did the update fix things for you?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Internal Server error’ is closed to new replies.