Support » Fixing WordPress » Internal Server errod wordpress and godaddy

  • I have godaddy hosting and receiving internal server error message while trying to log in to dashboard and while trying the front end. But sometimes site works fine.

    this is the log error gernerated. Please help

    Tue Aug 28 05:18:35 2012] [warn] [client] mod_fcgid: read data timeout in 120 seconds
    [Tue Aug 28 05:18:35 2012] [error] [client] Premature end of script headers: index.php
    [Tue Aug 28 05:19:10 2012] [warn] [client] mod_fcgid: read data timeout in 120 seconds
    [Tue Aug 28 05:19:10 2012] [error] [client] Premature end of script headers: index.php

    [truncated by forum mod]

Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.


    Godaddy failed to notify thousands of website owners that they were upgrading their PHP on the hosting servers. Some of the errors will have to be corrected one line at a time. The errors you are seeing are only part of it, once those are corrected, we have seen many more pop-up. We have been charging customers $200 and up to fix them in about one day with great results. If you are not skilled at fixing lines of code, please call a professional company…GODADDY WILL NOT HELP YOU!! You can email me directly at and I will help you or point you in the right direction. We can fix WordPress or e-commerce websites with the PHP errors. Thanks!



    We’d love to help you, but we would need more information from you to troubleshoot. I’d highly recommend submitted a support request here: You can respond to this forum post with the Incident number you receive and I can make sure it gets expedited with our advanced hosting team for review.

    Regarding the PHP upgrade, all of our customers were notifed months in advance and you are welcome to review more information regarding that upgrade here:

    Please do not assume that this is what is causing the issue. We’d truly like to review and see what’s going on before jumping to any conclusions. Once I have your incident number, we’ll be able to dive in a bit deeper and help you out.


    Just to clarify. I purchased a theme from Elegant Themes (Nimble) and loaded up to a fresh Godaddy install of WordPress (no plugins). I received the error above in the server logs. Sent Godaddy an email and this is the response I got:

    Thank you for contacting Online Support. We understand you are inquiring about an error you are receiving on your hosting account. Upon reviewing the account we find that your website is referencing itself using http connections. This code is creating a loop of requests on the server. You will need to review your code and remove any reference to your own website using the http connection.

    This is a theme issue with the PHP version because when I disable the theme WordPress loads fine. But this is probably the most indecipherable support email I have ever seen.

    It sounds like the theme is causing a redirect loop of some sort, though, again, without more information I’m merely guessing.

    Please post back with the incident number and I’ll be able to dig deeper for you.

    However, if removing the theme did resolve the issue, then it’s something in the theme’s code that’s creating it. I can’t guarantee we can find a solution for the code issue, but it’s definitely worth looking at.

    Let me know that number and I’ll see what I find out.


    Incident # is: 16736482. Elegantthemes says it is the host. Is it because it is loading more than 50 resources at once from the server? I do not understand what support wrote back to me. I am very experienced with wordpress codex and have not seen this issue before.


    Updraded to the Deluxe version and same issue. This is either Elegant Themes or Godaddy but it is really killing me.

    Godaddy is not going to solve the. Issue. After being in trouble with godaddy hosting for months without proper support I switched over to bluehost, believe there were no downtime for more than two months now after being going down everyday with godaddy.

    I guess this didn’t mean anything:

    Let me know that number and I’ll see what I find out.

    I always thought GoDaddy was over-criticized. Not so sure now.

    Wish I had not paid for a year on 4 accounts. I will go elsewhere for hosting. Stinks though, would prefer to have it in one place.


    My apologies to you. This thread was overlooked while some staff was out of the office. We should have responded sooner.

    What the support response was saying is that the code of the site is causing a loop. Meaning, there is essentially a near-never-ending request for the page or some element on the page, possibly the effect of each request causing an additional request. Eventually, this causes the user to hit the maximum concurrent connections allowed for the account which is what a 503 error normally indicates.

    Often, when we see a 503 error, this is because of legitimate traffic causing the site to hit its max connections. Regarding the upgrade to Deluxe, I assume a representative suggested that to you when they saw the 503 error since, in those legitimate traffic situations, an upgrade would help by raising the limit for the account. However, in your case, it’s a coding issue causing an abnormal spike in connections which would hit the limit of a Deluxe account as well. So, for you, upgrading is not the answer. If you don’t need the upgrade, you’re welcome to downgrade back to the Economy plan. Just let me know, and I’ll review the billing ramifications.

    Unfortunately, what I can’t diagnose is the exact code that’s causing the problem. Since you only see it when using the Nimble theme, I must recommend contacting the theme’s author for assistance or switching to another theme you find suitable. I apologize that I can’t do more to resolve the issue.

    Please let me know if there’s another area where we could assist or if you choose to perform the downgrade.

    Good luck to you,


    I would love to downgrade if possible. I got the issue resolved. Hopefully.


    That’s no problem. Just perform the downgrade in your account and let me know that you have… or you can call Support afterwards. I’ve already notated your account explaining the situation.

    Glad to hear you got it working, by the way. Was it a simple tweak?


Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Internal Server errod wordpress and godaddy’ is closed to new replies.